aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-05-26 20:56:35 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-05-26 20:56:35 +0800
commit582ad8ca4dd95f1eab4856fafb1eec9788607617 (patch)
treed3c516da811fcb16c9a782ce9e212798ebebdf79 /mail
parent9bfc6d84029c3ab94d0d991d39378bac6a7331c9 (diff)
downloadfreebsd-ports-graphics-582ad8ca4dd95f1eab4856fafb1eec9788607617.tar.gz
freebsd-ports-graphics-582ad8ca4dd95f1eab4856fafb1eec9788607617.tar.zst
freebsd-ports-graphics-582ad8ca4dd95f1eab4856fafb1eec9788607617.zip
mail/opensmtpd: Fix SSL and CA problems
- Change with-ssl to with-ssllib - Change with-ca-file to with-path-CAfile - Remove broken for libasr-devel PR: 208991 Submitted by: fluffy Approved by: maintainer (implicit)
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 9fdf642c2f6..e0b41e1cbee 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -42,12 +42,11 @@ GROUPS= _smtpd _smtpq
OPTIONS_SUB= yes
-CA_BUNDLE_CONFIGURE_WITH= ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_CONFIGURE_WITH= path-CAfile=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
LIBASRDEVEL_LIB_DEPENDS_OFF= libasr.so:dns/libasr
LIBASRDEVEL_LIB_DEPENDS= libasr.so:dns/libasr-devel
-LIBASRDEVEL_BROKEN= incompatible with libasr-devel
PAM_CONFIGURE_WITH= auth-pam=smtpd
SSL_PORT_VARS= with_openssl_port=yes
@@ -63,7 +62,7 @@ WITH_OPENSSL_PORT= yes
CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
--with-libevent=${LOCALBASE} \
- --with-ssl=${OPENSSLBASE} \
+ --with-libssl=${OPENSSLBASE} \
--sysconfdir=${PREFIX}/etc/mail/
post-patch: