aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-02-09 19:43:38 +0800
committerale <ale@FreeBSD.org>2004-02-09 19:43:38 +0800
commit64c967a3b7bc5eff3ae52eb167cf7cae1d817643 (patch)
tree5a5b7919d0c88fe51071c6e66890b4b3fd4e7bf7 /mail
parentb6a56540b211f28c52e6af62d7ac3d5a3e01a34c (diff)
downloadfreebsd-ports-graphics-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.tar.gz
freebsd-ports-graphics-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.tar.zst
freebsd-ports-graphics-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.zip
Remove lang/php4/bsd.php.mk and switch every ports depending on PHP to
use Mk/bsd.php.mk. Approved by: nork (mentor/implicitly)
Diffstat (limited to 'mail')
-rw-r--r--mail/nocc/Makefile6
-rw-r--r--mail/pear-mailparse/Makefile2
-rw-r--r--mail/pecl-mailparse/Makefile2
-rw-r--r--mail/squirrelmail/Makefile6
4 files changed, 6 insertions, 10 deletions
diff --git a/mail/nocc/Makefile b/mail/nocc/Makefile
index 7bc939bffc9..0840e02a68e 100644
--- a/mail/nocc/Makefile
+++ b/mail/nocc/Makefile
@@ -14,14 +14,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= A web-based e-mail system which access POP3 and IMAP mail servers
+USE_PHP= yes
WANT_PHP_WEB= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
NO_BUILD= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
-
pre-everything::
@${ECHO} ""
@${ECHO} "You have to configure PHP with IMAP support in order"
@@ -54,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-mailparse/Makefile b/mail/pear-mailparse/Makefile
index 02d21ea620f..aca31da3ee9 100644
--- a/mail/pear-mailparse/Makefile
+++ b/mail/pear-mailparse/Makefile
@@ -17,10 +17,10 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
IS_INTERACTIVE= 'need to build php4 with mbstring support.'
+USE_PHP= yes
USE_PHPIZE= yes
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/mail/pecl-mailparse/Makefile b/mail/pecl-mailparse/Makefile
index 02d21ea620f..aca31da3ee9 100644
--- a/mail/pecl-mailparse/Makefile
+++ b/mail/pecl-mailparse/Makefile
@@ -17,10 +17,10 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
IS_INTERACTIVE= 'need to build php4 with mbstring support.'
+USE_PHP= yes
USE_PHPIZE= yes
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 14b4e895b76..bdd39fdc20e 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -17,6 +17,7 @@ COMMENT?= A webmail system which accesses mail over IMAP
CONFLICTS?= ja-squirrelmail-1.*
+USE_PHP= yes
WANT_PHP_WEB= yes
USE_BZIP2= yes
@@ -38,9 +39,6 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} \
MASTERDIR= ${.CURDIR}
.endif
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
-
pre-everything::
@${ECHO_CMD} "SquirrelMail is installed into ${SQUIRRELDIR}"
@${ECHO_CMD} "To use the old location ${PREFIX}/squirrelmail define"
@@ -105,4 +103,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>