aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-10 07:19:58 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-10 07:19:58 +0800
commit7289e06ac15e198b5774fe53883461f3b238c366 (patch)
tree0af28e7c763e699461c7ffb26d2b6e0bbf2b532d /mail
parent1f478761278cef298be0b1813993bca61316b1e2 (diff)
downloadfreebsd-ports-graphics-7289e06ac15e198b5774fe53883461f3b238c366.tar.gz
freebsd-ports-graphics-7289e06ac15e198b5774fe53883461f3b238c366.tar.zst
freebsd-ports-graphics-7289e06ac15e198b5774fe53883461f3b238c366.zip
Mail Avenger is a highly-configurable, MTA-independent SMTP server
daemon. It lets users run messages through filters like ClamAV and SpamAssassin during SMTP transactions, so the server can reject mail before assuming responsibility for its delivery. Other unique features include TCP SYN fingerprint and network route recording, verification of sender addresses through SMTP callbacks, SPF (sender policy framework) as a general policy language, qmail-style control over both SMTP-level behavior and local delivery of extension addresses, mail-bomb protection, integration with kernel firewalls, and more. WWW: http://www.mailavenger.org/ PR: ports/80800 Submitted by: David Mazieres <dm+bugs+avenger@mailavenger.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/avenger/Makefile38
-rw-r--r--mail/avenger/distinfo2
-rw-r--r--mail/avenger/pkg-deinstall32
-rw-r--r--mail/avenger/pkg-descr11
-rw-r--r--mail/avenger/pkg-install61
-rw-r--r--mail/avenger/pkg-plist14
7 files changed, 159 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4974b18c3e2..ef979cf911b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -19,6 +19,7 @@
SUBDIR += asmail
SUBDIR += autorespond
SUBDIR += autosig
+ SUBDIR += avenger
SUBDIR += balsa
SUBDIR += bayespam
SUBDIR += bbmail
diff --git a/mail/avenger/Makefile b/mail/avenger/Makefile
new file mode 100644
index 00000000000..a9b6e7d2ee0
--- /dev/null
+++ b/mail/avenger/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: avenger
+# Date created: 8 May 2005
+# Whom: dm
+#
+# $FreeBSD$
+#
+
+PORTNAME= avenger
+PORTVERSION= 0.6.2
+CATEGORIES= mail
+MASTER_SITES= http://www.mailavenger.org/dist/
+
+MAINTAINER= dm+bug+avenger@mailavenger.org
+COMMENT= An anti-spam SMTP server
+
+LIB_DEPENDS= db-4.3:${PORTSDIR}/databases/db43
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= aliascheck.1 avenger.1 dbutil.1 deliver.1 dotlock.1 \
+ edinplace.1 macutil.1 mailexec.1 match.1 smtpdcheck.1 synos.1
+MAN5= asmtpd.conf.5
+MAN8= asmtpd.8 avenger.local.8
+
+CONFIGURE_ARGS= --with-db=${LOCALBASE}
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -e \
+ 's|\(/etc/avenger\)|${PREFIX}\1|g' {} \;
+
+pre-install:
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+
+post-install:
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/mail/avenger/distinfo b/mail/avenger/distinfo
new file mode 100644
index 00000000000..e9d70f8c79a
--- /dev/null
+++ b/mail/avenger/distinfo
@@ -0,0 +1,2 @@
+MD5 (avenger-0.6.2.tar.gz) = 40d81f693192d79c1c1a3070f6df54d7
+SIZE (avenger-0.6.2.tar.gz) = 756450
diff --git a/mail/avenger/pkg-deinstall b/mail/avenger/pkg-deinstall
new file mode 100644
index 00000000000..74fdb43ba02
--- /dev/null
+++ b/mail/avenger/pkg-deinstall
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+USER=avenger
+GROUP=avenger
+AVDIR=/var/spool/avenger
+AVETC=${PKG_PREFIX}/etc/avenger
+
+PW=/usr/sbin/pw
+
+if ${PW} groupshow "${GROUP}" >/dev/null 2>&1; then
+ echo "If you're done with Mail Avenger permanently, delete the $GROUP group manually: pw groupdel ${GROUP}" | fmt
+fi
+
+if ${PW} usershow "${USER}" >/dev/null 2>&1; then
+ echo
+ echo "If you're done with Mail Avenger permanently, delete the $USER user manually: pw userdel ${USER}" | fmt
+fi
+
+for dir in "$AVETC" "$AVDIR"; do
+ if [ -d "$dir" ] && ! rmdir $dir 2>/dev/null; then
+ echo
+ echo "You may wish to investigate the contents of $dir and delete the directory if you're done with Mail Avenger permanently." | fmt
+ fi
+done
diff --git a/mail/avenger/pkg-descr b/mail/avenger/pkg-descr
new file mode 100644
index 00000000000..60dc687f4cc
--- /dev/null
+++ b/mail/avenger/pkg-descr
@@ -0,0 +1,11 @@
+Mail Avenger is a highly-configurable, MTA-independent SMTP server
+daemon. It lets users run messages through filters like ClamAV and
+SpamAssassin during SMTP transactions, so the server can reject mail
+before assuming responsibility for its delivery. Other unique features
+include TCP SYN fingerprint and network route recording, verification
+of sender addresses through SMTP callbacks, SPF (sender policy
+framework) as a general policy language, qmail-style control over both
+SMTP-level behavior and local delivery of extension addresses,
+mail-bomb protection, integration with kernel firewalls, and more.
+
+WWW: http://www.mailavenger.org/
diff --git a/mail/avenger/pkg-install b/mail/avenger/pkg-install
new file mode 100644
index 00000000000..03780480e38
--- /dev/null
+++ b/mail/avenger/pkg-install
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+USER=avenger
+GROUP=avenger
+UID=172
+GID=172
+AVDIR=/var/spool/avenger
+AVETC=${PKG_PREFIX}/etc/avenger
+
+PW=/usr/sbin/pw
+
+
+if [ "$2" = "PRE-INSTALL" ]; then
+ echo -n "Checking for group '$GROUP'... "
+
+ if ! ${PW} groupshow $GROUP >/dev/null 2>&1; then
+ echo -n "doesn't exist, adding... "
+ if ${PW} groupadd $GROUP -g ${GID}; then
+ echo "success."
+ else
+ echo "FAILED!"
+ exit 1
+ fi
+ else
+ echo "exists."
+ fi
+
+ echo -n "Checking for user '$USER'... "
+
+ if ! ${PW} usershow $USER >/dev/null 2>&1; then
+ echo -n "doesn't exist, adding... "
+ if ${PW} useradd $USER -u ${UID} -c 'Mail Avenger' -d "$AVDIR" -g $GROUP -s /sbin/nologin -h -; then
+ echo "success."
+ else
+ echo "FAILED!"
+ exit 1
+ fi
+ else
+ echo "exists."
+ fi
+elif [ "$2" = "POST-INSTALL" ]; then
+ echo -n "Checking for config directory ($AVETC)... "
+
+ if [ -d "$AVETC" ]; then
+ echo "already exists."
+ else
+ echo -n "creating... "
+ if mkdir $AVETC; then
+ echo "success."
+ else
+ echo "FAILED!"
+ exit 1
+ fi
+ fi
+fi
+
+exit 0
diff --git a/mail/avenger/pkg-plist b/mail/avenger/pkg-plist
new file mode 100644
index 00000000000..f57a14cd236
--- /dev/null
+++ b/mail/avenger/pkg-plist
@@ -0,0 +1,14 @@
+bin/aliascheck
+bin/dbutil
+bin/deliver
+bin/dotlock
+bin/edinplace
+bin/macutil
+bin/mailexec
+bin/match
+bin/smtpdcheck
+bin/synos
+libexec/avenger
+libexec/avenger.local
+sbin/asmtpd
+share/pf.os