aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-01-04 23:53:39 +0800
committerseanc <seanc@FreeBSD.org>2003-01-04 23:53:39 +0800
commit7a4235bd87966a4520aa5d2fd21abe0a5207c0d6 (patch)
treefd0f8a3c3c97bdaf70a19f3c37d60eb594efca77 /mail
parent880560345484112b8efb832f54fd47105704bc7e (diff)
downloadfreebsd-ports-graphics-7a4235bd87966a4520aa5d2fd21abe0a5207c0d6.tar.gz
freebsd-ports-graphics-7a4235bd87966a4520aa5d2fd21abe0a5207c0d6.tar.zst
freebsd-ports-graphics-7a4235bd87966a4520aa5d2fd21abe0a5207c0d6.zip
Chase libpq version bump.
Diffstat (limited to 'mail')
-rw-r--r--mail/exim-old/Makefile4
-rw-r--r--mail/exim/Makefile4
-rw-r--r--mail/ezmlm-idx/Makefile3
-rw-r--r--mail/horde-imp/Makefile2
-rw-r--r--mail/horde-turba/Makefile2
-rw-r--r--mail/horde4-imp/Makefile2
-rw-r--r--mail/horde4-turba/Makefile2
-rw-r--r--mail/imp/Makefile2
-rw-r--r--mail/imp3/Makefile2
-rw-r--r--mail/teapop-devel/Makefile3
-rw-r--r--mail/teapop/Makefile3
-rw-r--r--mail/turba/Makefile2
12 files changed, 19 insertions, 12 deletions
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index d5b890c5c5d..35c0f0196a9 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -24,6 +24,8 @@ PKGMESSAGE= ${FILESDIR}/POST-INSTALL-NOTES
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+POSTGRESQL_PORT?= databases/postgresql7
+
# If WITH_EXIMON is defined, the eximon monitor, which requires X,
# will be made a dependency. Note that using WITH_EXIMON will cause
# XFree86 to be installed if it is not present.
@@ -150,7 +152,7 @@ SEDLIST+= -e 's,^\# AUTH_PLAINTEXT=,AUTH_PLAINTEXT=,'
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${LOCALBASE}/lib -lpq,' \
-e 's,XX_PGSQL_INCLUDE_XX,-I${LOCALBASE}/include/pgsql,' \
-e 's,^\# LOOKUP_PGSQL=,LOOKUP_PGSQL=,'
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index e9128a5cf6f..3b86cccc63e 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -39,6 +39,8 @@ PKGMESSAGE= ${WRKDIR}/POST-INSTALL-NOTES
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+POSTGRESQL_PORT?= databases/postgresql7
+
# If WITH_EXIMON is defined, the eximon monitor, which requires X,
# will be made a dependency. Note that using WITH_EXIMON will cause
# XFree86 to be installed if it is not present.
@@ -205,7 +207,7 @@ SEDLIST+= -e 's,^\# AUTH_PLAINTEXT=,AUTH_PLAINTEXT=,'
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${LOCALBASE}/lib -lpq,' \
-e 's,XX_PGSQL_INCLUDE_XX,-I${LOCALBASE}/include/pgsql,' \
-e 's,^\# LOOKUP_PGSQL=,LOOKUP_PGSQL=,'
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index 2887b082179..2232a42c803 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -42,7 +42,8 @@ EXTRACT_INCLUDE+= -I${PREFIX}/include/mysql
EXTRACT_LIB+= -L${PREFIX}/lib/mysql -lmysqlclient -lm
.elif defined(WITH_POSTGRESQL)
ALL_TARGET= pgsql it ${LANGUAGE}
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
EXTRACT_INCLUDE+= -I${PREFIX}/include/pgsql
EXTRACT_LIB+= -L${PREFIX}/lib -lpq -lcrypt
.else
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index d71c04a3b82..cd7294b35e7 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index 850e007e9ae..46f7c46b9be 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde4-imp/Makefile b/mail/horde4-imp/Makefile
index d71c04a3b82..cd7294b35e7 100644
--- a/mail/horde4-imp/Makefile
+++ b/mail/horde4-imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index 850e007e9ae..46f7c46b9be 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index d71c04a3b82..cd7294b35e7 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index 1b4206389c6..4345211cea9 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -212,7 +212,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/teapop-devel/Makefile b/mail/teapop-devel/Makefile
index d002ae40140..c2fc9446a88 100644
--- a/mail/teapop-devel/Makefile
+++ b/mail/teapop-devel/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
MAINTAINER= ports@FreeBSD.org
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
.if defined(WITH_MYSQL)
diff --git a/mail/teapop/Makefile b/mail/teapop/Makefile
index d002ae40140..c2fc9446a88 100644
--- a/mail/teapop/Makefile
+++ b/mail/teapop/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
MAINTAINER= ports@FreeBSD.org
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
.if defined(WITH_MYSQL)
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index 850e007e9ae..46f7c46b9be 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \