aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-07-06 03:31:37 +0800
committeradamw <adamw@FreeBSD.org>2016-07-06 03:31:37 +0800
commit7a77d2d9a88aba45f09929958384ab45d2880cbd (patch)
tree6547c729ab1bb86cee8e8d108b5e07f9aa25e4d7 /mail
parent0318af8d7d2b9b6b0e208c412c4dc842e9b9f075 (diff)
downloadfreebsd-ports-graphics-7a77d2d9a88aba45f09929958384ab45d2880cbd.tar.gz
freebsd-ports-graphics-7a77d2d9a88aba45f09929958384ab45d2880cbd.tar.zst
freebsd-ports-graphics-7a77d2d9a88aba45f09929958384ab45d2880cbd.zip
Fix build on 9.x.
Adds compiler:c11 for this error: sha1.h:80: error: static or type qualifiers in abstract declarator dovecot no longer builds againt the old OpenSSL in 9.x base, so require ssl from ports there. Despite the dependency change (only for 9.x), I'm not bumping PORTREVISION because build couldn't complete on 9.x regardless.
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot2/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 63611734e83..a12cc8a052c 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -135,6 +135,13 @@ PGSQL_VARS= _REQUIRE+=postgresql
SUB_LIST+= REQUIRE="${_REQUIRE}"
SUB_FILES+= pkg-message
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000011
+USES+= compiler:c11
+WITH_OPENSSL_PORT= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
LDFLAGS+= -L${LOCALBASE}/lib -I${OPENSSLLIB}
@@ -160,4 +167,4 @@ post-install-EXAMPLES-on:
${MV} ${STAGEDIR}${DOCSDIR}/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
${MV} ${STAGEDIR}${DOCSDIR}/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>