aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-07-14 04:11:56 +0800
committercrees <crees@FreeBSD.org>2011-07-14 04:11:56 +0800
commit813948f7b7cedbb52425ea136936f938eb76c91b (patch)
treee746697b908500a44be4244ea01985d85bcec042 /mail
parent457e3a8f49a70d5e32d7798458cb2f2e83cd4978 (diff)
downloadfreebsd-ports-graphics-813948f7b7cedbb52425ea136936f938eb76c91b.tar.gz
freebsd-ports-graphics-813948f7b7cedbb52425ea136936f938eb76c91b.tar.zst
freebsd-ports-graphics-813948f7b7cedbb52425ea136936f938eb76c91b.zip
- Add RUN_DEPENDS entries for extra dependencies after RUN_DEPENDS:=${BUILD_DEPENDS} line -- only started to be necessary when I added the colon
- DB_TYPE is no longer case sensitive Approved by: rene (mentor, implicit)
Diffstat (limited to 'mail')
-rw-r--r--mail/sympa/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 864a64110b8..fb6d1145682 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -93,17 +93,23 @@ USE_MYSQL= yes
.if defined(WITH_FASTCGI)
BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
+RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
+ ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
.endif
-.if ${DB_TYPE} == "Oracle"
+.if ${DB_TYPE:L} == "oracle"
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
-.elif ${DB_TYPE} == "Pg"
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
+.elif ${DB_TYPE:L} == "pg"
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-.elif ${DB_TYPE} == "Sybase"
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.elif ${DB_TYPE:L} == "sybase"
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Sybase.pm:${PORTSDIR}/databases/p5-DBD-Sybase
-.elif ${DB_TYPE} == "mysql"
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Sybase.pm:${PORTSDIR}/databases/p5-DBD-Sybase
+.elif ${DB_TYPE:L} == "mysql"
. if exists (${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}/Makefile)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
. else
IGNORE= Your MySQL installation is at ${MYSQL_VER}, and there is no p5-DBD-mysql${MYSQL_VER} port
. endif