aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2014-06-10 21:09:09 +0800
committerfeld <feld@FreeBSD.org>2014-06-10 21:09:09 +0800
commit82e637889131c5c2479d547cd827b301fb487ca5 (patch)
tree84fda9a684c3d3cfdead141b2e710917b3447e2d /mail
parent1c35002345f65c7a06e4dcaadbc4975f94b54123 (diff)
downloadfreebsd-ports-graphics-82e637889131c5c2479d547cd827b301fb487ca5.tar.gz
freebsd-ports-graphics-82e637889131c5c2479d547cd827b301fb487ca5.tar.zst
freebsd-ports-graphics-82e637889131c5c2479d547cd827b301fb487ca5.zip
Fix building with Clang on 10.0+
Diffstat (limited to 'mail')
-rw-r--r--mail/relaydb/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/mail/relaydb/Makefile b/mail/relaydb/Makefile
index e85ab33db96..a57c8a96a5d 100644
--- a/mail/relaydb/Makefile
+++ b/mail/relaydb/Makefile
@@ -12,6 +12,9 @@ COMMENT= Spam relay database
PLIST_FILES= bin/relaydb \
man/man8/relaydb.8.gz
+post-patch:
+ ${REINPLACE_CMD} 's|-Werror|-Wno-error|' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/relaydb ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/relaydb.8.gz ${STAGEDIR}${MAN8PREFIX}/man/man8