aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-05-10 21:11:51 +0800
committergarga <garga@FreeBSD.org>2006-05-10 21:11:51 +0800
commit8ade70bcd0b3cc1dae01c6017f616889a5853498 (patch)
treef50a9d7d22efa1126692cb4d04ffbf5367ef52a6 /mail
parent076ff92abb92b05fa851ca8deebf89908e4ab723 (diff)
downloadfreebsd-ports-graphics-8ade70bcd0b3cc1dae01c6017f616889a5853498.tar.gz
freebsd-ports-graphics-8ade70bcd0b3cc1dae01c6017f616889a5853498.tar.zst
freebsd-ports-graphics-8ade70bcd0b3cc1dae01c6017f616889a5853498.zip
This plugin assists in keeping the addressbook of a Windows CE device
(Pocket PC/ iPAQ, Smartphone etc) in sync with Claws' addressbook, with respect to email addresses. PR: ports/95446 Submitted by: Pawel Pekala <c0rn@o2.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-synce/Makefile33
-rw-r--r--mail/claws-mail-synce/distinfo3
-rw-r--r--mail/claws-mail-synce/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-synce/pkg-descr3
-rw-r--r--mail/sylpheed-claws-synce/Makefile33
-rw-r--r--mail/sylpheed-claws-synce/distinfo3
-rw-r--r--mail/sylpheed-claws-synce/files/patch-configure.ac15
-rw-r--r--mail/sylpheed-claws-synce/pkg-descr3
9 files changed, 109 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 901ef06b318..c11982cb10e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -535,6 +535,7 @@
SUBDIR += sylpheed-claws-notification
SUBDIR += sylpheed-claws-perl
SUBDIR += sylpheed-claws-smime
+ SUBDIR += sylpheed-claws-synce
SUBDIR += sylpheed-claws-vcalendar
SUBDIR += sylpheed2
SUBDIR += sympa
diff --git a/mail/claws-mail-synce/Makefile b/mail/claws-mail-synce/Makefile
new file mode 100644
index 00000000000..a06ad365751
--- /dev/null
+++ b/mail/claws-mail-synce/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sylpheed-claws-synce
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= synce
+PORTVERSION= 0.6
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= synce_plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Windows CE addressbook plugin for sylpheed-claws
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+CONFIGURE_ARGS= --with-libsynce=${LOCALBASE} \
+ --with-librapi2=${LOCALBASE}
+
+PLIST_FILES= lib/sylpheed-claws/plugins/synce_plugin.a \
+ lib/sylpheed-claws/plugins/synce_plugin.la \
+ lib/sylpheed-claws/plugins/synce_plugin.so
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-synce/distinfo b/mail/claws-mail-synce/distinfo
new file mode 100644
index 00000000000..0d6f9e6a5e2
--- /dev/null
+++ b/mail/claws-mail-synce/distinfo
@@ -0,0 +1,3 @@
+MD5 (synce_plugin-0.6.tar.gz) = d7448658635543893a27b7954dad9e5f
+SHA256 (synce_plugin-0.6.tar.gz) = 8dde775a4cc5dd75d1cf9919eafc6a0dec7bd8084efe0625d8f04ec3485c8088
+SIZE (synce_plugin-0.6.tar.gz) = 324491
diff --git a/mail/claws-mail-synce/files/patch-configure.ac b/mail/claws-mail-synce/files/patch-configure.ac
new file mode 100644
index 00000000000..3806f6a8cd6
--- /dev/null
+++ b/mail/claws-mail-synce/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:46:08 2006
++++ configure.ac Wed Apr 5 20:47:02 2006
+@@ -42,7 +42,11 @@
+
+ dnl check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+-SYLPHEED_CLAWS_PLUGINDIR=$($PKG_CONFIG --variable=plugindir sylpheed-claws)
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$($PKG_CONFIG --variable=plugindir sylpheed-claws)
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-synce/pkg-descr b/mail/claws-mail-synce/pkg-descr
new file mode 100644
index 00000000000..506d58b0841
--- /dev/null
+++ b/mail/claws-mail-synce/pkg-descr
@@ -0,0 +1,3 @@
+This plugin assists in keeping the addressbook of a Windows CE device
+(Pocket PC/ iPAQ, Smartphone etc) in sync with Claws' addressbook,
+with respect to email addresses.
diff --git a/mail/sylpheed-claws-synce/Makefile b/mail/sylpheed-claws-synce/Makefile
new file mode 100644
index 00000000000..a06ad365751
--- /dev/null
+++ b/mail/sylpheed-claws-synce/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sylpheed-claws-synce
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= synce
+PORTVERSION= 0.6
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= synce_plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Windows CE addressbook plugin for sylpheed-claws
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+CONFIGURE_ARGS= --with-libsynce=${LOCALBASE} \
+ --with-librapi2=${LOCALBASE}
+
+PLIST_FILES= lib/sylpheed-claws/plugins/synce_plugin.a \
+ lib/sylpheed-claws/plugins/synce_plugin.la \
+ lib/sylpheed-claws/plugins/synce_plugin.so
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-synce/distinfo b/mail/sylpheed-claws-synce/distinfo
new file mode 100644
index 00000000000..0d6f9e6a5e2
--- /dev/null
+++ b/mail/sylpheed-claws-synce/distinfo
@@ -0,0 +1,3 @@
+MD5 (synce_plugin-0.6.tar.gz) = d7448658635543893a27b7954dad9e5f
+SHA256 (synce_plugin-0.6.tar.gz) = 8dde775a4cc5dd75d1cf9919eafc6a0dec7bd8084efe0625d8f04ec3485c8088
+SIZE (synce_plugin-0.6.tar.gz) = 324491
diff --git a/mail/sylpheed-claws-synce/files/patch-configure.ac b/mail/sylpheed-claws-synce/files/patch-configure.ac
new file mode 100644
index 00000000000..3806f6a8cd6
--- /dev/null
+++ b/mail/sylpheed-claws-synce/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:46:08 2006
++++ configure.ac Wed Apr 5 20:47:02 2006
+@@ -42,7 +42,11 @@
+
+ dnl check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+-SYLPHEED_CLAWS_PLUGINDIR=$($PKG_CONFIG --variable=plugindir sylpheed-claws)
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$($PKG_CONFIG --variable=plugindir sylpheed-claws)
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/sylpheed-claws-synce/pkg-descr b/mail/sylpheed-claws-synce/pkg-descr
new file mode 100644
index 00000000000..506d58b0841
--- /dev/null
+++ b/mail/sylpheed-claws-synce/pkg-descr
@@ -0,0 +1,3 @@
+This plugin assists in keeping the addressbook of a Windows CE device
+(Pocket PC/ iPAQ, Smartphone etc) in sync with Claws' addressbook,
+with respect to email addresses.