aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-04 02:02:02 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-04 02:02:02 +0800
commit900feaf8082d74bd8cd903621f2f9a9cf801f652 (patch)
tree3784b2908a9d58b42b0bca00ef5ca0a54629da89 /mail
parentf5ca13e6c2f1c8a43a9db3f00c66b349cbf09205 (diff)
downloadfreebsd-ports-graphics-900feaf8082d74bd8cd903621f2f9a9cf801f652.tar.gz
freebsd-ports-graphics-900feaf8082d74bd8cd903621f2f9a9cf801f652.tar.zst
freebsd-ports-graphics-900feaf8082d74bd8cd903621f2f9a9cf801f652.zip
This is a port of tmdatools plugin for Squirrelmail.
This plugin allows a TMDA enabled account to be managed from within the SquirrelMail interface, including the ability to edit list files, add control headers to outgoing email, manage pending messages and create tagged addresses for use outside SquirrelMail. WWW: http://www.morison.net/squirrelmail-plugins/tmdatools.html PR: ports/98757 Submitted by: Raul Pollicino <email-freebsd at def-defying.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-tmda-plugin/Makefile59
-rw-r--r--mail/squirrelmail-tmda-plugin/distinfo3
-rw-r--r--mail/squirrelmail-tmda-plugin/pkg-descr8
-rw-r--r--mail/squirrelmail-tmda-plugin/pkg-plist18
5 files changed, 89 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 933792cb2a4..5e957512106 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -538,6 +538,7 @@
SUBDIR += squirrelmail-quota_usage-plugin
SUBDIR += squirrelmail-secure_login-plugin
SUBDIR += squirrelmail-timeout_user-plugin
+ SUBDIR += squirrelmail-tmda-plugin
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += squirrelmail-websearch-plugin
SUBDIR += squirrelmail-wetteronline-plugin
diff --git a/mail/squirrelmail-tmda-plugin/Makefile b/mail/squirrelmail-tmda-plugin/Makefile
new file mode 100644
index 00000000000..07aede2fb3a
--- /dev/null
+++ b/mail/squirrelmail-tmda-plugin/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: squirrelmail-tmda-plugin
+# Date created: 2006-06-10
+# Whom: Raul Pollicino <email-freebsd@def-defying.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-tmda-plugin
+PORTVERSION= 1.0.2
+CATEGORIES= mail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= tmdatools 1.0.2 1.4.2 \(stable\)
+DISTFILES= tmdatools.1.0.2-1.4.2.tar.gz
+
+MAINTAINER= email-ports@def-defying.com
+COMMENT= Adds TMDA support to SquirrelMail
+
+RUN_DEPENDS= tmda-filter:${PORTSDIR}/mail/tmda \
+ ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+SQUIRREL_PLUGIN_NAME= tmdatools
+WRKSRC= ${WRKDIR}/tmdatools
+
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+.else
+SQUIRRELDIR?= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+.endif
+TMDATOOLDIR?= ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+PLIST_SUB+= TMDATOOLDIR=plugins/${SQUIRREL_PLUGIN_NAME}
+
+pre-everything::
+ @${ECHO} "The plugin expects SquirrelMail install in ${SQUIRRELDIR}"
+ @${ECHO} "To use the old location ${PREFIX}/squirrelmail define WITHOUT_WWWDIR=yes"
+ @${ECHO} ""
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|"/usr/local/tmda-1.0.2/"|${TMDATOOLDIR}|g' \
+ ${WRKSRC}/tmdatools_config.php.sample
+ @${RM} ${WRKSRC}/tmdatools_config.php.sample.bak
+
+do-install:
+ @${MKDIR} ${TMDATOOLDIR}
+ @${CP} -Rp ${WRKSRC}/ ${TMDATOOLDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${TMDATOOLDIR}
+ @${RM} -f ${WRKSRC}/tmdatools_config.php.sample.bak
+
+post-install:
+ @${ECHO} ""
+ @${ECHO} "Refer to ${TMDATOOLDIR}/INSTALL and README for final installation/configuration instructions."
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-tmda-plugin/distinfo b/mail/squirrelmail-tmda-plugin/distinfo
new file mode 100644
index 00000000000..8ded7562b5c
--- /dev/null
+++ b/mail/squirrelmail-tmda-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (tmdatools.1.0.2-1.4.2.tar.gz) = d1d5ef4a89d5490caf7c5b67e4c1f6ee
+SHA256 (tmdatools.1.0.2-1.4.2.tar.gz) = 2722e783ca579fa963843419793fd06deb3029ec6ba31878cca1729f67d9980d
+SIZE (tmdatools.1.0.2-1.4.2.tar.gz) = 17347
diff --git a/mail/squirrelmail-tmda-plugin/pkg-descr b/mail/squirrelmail-tmda-plugin/pkg-descr
new file mode 100644
index 00000000000..81434042649
--- /dev/null
+++ b/mail/squirrelmail-tmda-plugin/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of tmdatools plugin for Squirrelmail.
+
+This plugin allows a TMDA enabled account to be managed from within the
+SquirrelMail interface, including the ability to edit list files, add
+control headers to outgoing email, manage pending messages and create
+tagged addresses for use outside SquirrelMail.
+
+WWW: http://www.morison.net/squirrelmail-plugins/tmdatools.html
diff --git a/mail/squirrelmail-tmda-plugin/pkg-plist b/mail/squirrelmail-tmda-plugin/pkg-plist
new file mode 100644
index 00000000000..a30c6597e7d
--- /dev/null
+++ b/mail/squirrelmail-tmda-plugin/pkg-plist
@@ -0,0 +1,18 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin tmdatools; fi
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/COPYING
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/INSTALL
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/README
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/address.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/editfile.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/index.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/paginator.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/pending.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/setup.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/tmdatools.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/tmdatools_config.php.sample
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/tmdatools_findhome.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/tools.php
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/version
+%%SQUIRRELDIR%%/%%TMDATOOLDIR%%/viewer.php
+@dirrm %%SQUIRRELDIR%%/%%TMDATOOLDIR%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin tmdatools; fi