aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-17 03:55:31 +0800
committermiwi <miwi@FreeBSD.org>2008-02-17 03:55:31 +0800
commita95837a35292ce95c6d662c8aaad3deeb8451e7b (patch)
treec5ffac1d5bce0b1a8c5933bd77ebd07bb1d9dd2f /mail
parent8fa710af15b891fd5f49ec65d47826e4e842fc5e (diff)
downloadfreebsd-ports-graphics-a95837a35292ce95c6d662c8aaad3deeb8451e7b.tar.gz
freebsd-ports-graphics-a95837a35292ce95c6d662c8aaad3deeb8451e7b.tar.zst
freebsd-ports-graphics-a95837a35292ce95c6d662c8aaad3deeb8451e7b.zip
Clawsker is an applet to edit Claws Mail's hidden preferences.
Claws Mail has a high number of configurable options and, in order to keep the binary small and fast, some of these preferences which are not widely used are not provided with a graphical interface for inspection and/or modification. Users wanting to edit such preferences had to face editing the configuration text files directly, now it is possible with a convenient GTK2 interface using Clawsker. Other features: * Handling of all hidden preferences * Fully internationalized interface using gettext * Detection of running Claws Mail * Support for alternate configuration directories WWW: http://www.claws-mail.org/clawsker PR: ports/120681 Submitted by: Pawel Pekala <c0rn at o2.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/clawsker/Makefile28
-rw-r--r--mail/clawsker/distinfo3
-rw-r--r--mail/clawsker/files/patch-Makefile11
-rw-r--r--mail/clawsker/files/patch-clawsker11
-rw-r--r--mail/clawsker/pkg-descr19
6 files changed, 73 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 2d3cb6a08e2..7176e176a2e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -61,6 +61,7 @@
SUBDIR += claws-mail-synce
SUBDIR += claws-mail-tnef
SUBDIR += claws-mail-vcalendar
+ SUBDIR += clawsker
SUBDIR += cmail
SUBDIR += cone
SUBDIR += contact-lookup-applet
diff --git a/mail/clawsker/Makefile b/mail/clawsker/Makefile
new file mode 100644
index 00000000000..ff2cd97c73d
--- /dev/null
+++ b/mail/clawsker/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: clawsker
+# Date created: 2008-02-04
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clawsker
+PORTVERSION= 0.3.0
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/tools/
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Applet to edit Claws Mail's hidden preferences
+
+RUN_DEPENDS= claws-mail>=3.3.0:${PORTSDIR}/mail/claws-mail \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
+
+USE_PERL5= 5.8.0+
+USE_GETTEXT= yes
+
+MAN1= clawsker.1
+
+PLIST_FILES= bin/clawsker \
+ share/locale/es/LC_MESSAGES/clawsker.mo
+
+.include <bsd.port.mk>
diff --git a/mail/clawsker/distinfo b/mail/clawsker/distinfo
new file mode 100644
index 00000000000..a07226074f4
--- /dev/null
+++ b/mail/clawsker/distinfo
@@ -0,0 +1,3 @@
+MD5 (clawsker-0.3.0.tar.gz) = 0da26a5fbb9eed57f4b4839bf0f159f0
+SHA256 (clawsker-0.3.0.tar.gz) = 4294c19067b501c3d54b96b59514971a24ada39a8be55c5b22b0646494e05bce
+SIZE (clawsker-0.3.0.tar.gz) = 29524
diff --git a/mail/clawsker/files/patch-Makefile b/mail/clawsker/files/patch-Makefile
new file mode 100644
index 00000000000..2d3cb210f16
--- /dev/null
+++ b/mail/clawsker/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Mon Feb 4 23:32:18 2008
++++ Makefile Mon Feb 4 23:33:11 2008
+@@ -7,7 +7,7 @@
+ VERSION = $(shell cat VERSION)
+ PREFIX ?= /usr/local
+ BINDIR = ${PREFIX}/bin
+-DATADIR = ${PREFIX}/share
++DATADIR = ${PREFIX}
+ LIBDIR = ${PREFIX}/lib/${NAME}
+ MANDIR = ${DATADIR}/man
+ MAN1DIR = ${MANDIR}/man1
diff --git a/mail/clawsker/files/patch-clawsker b/mail/clawsker/files/patch-clawsker
new file mode 100644
index 00000000000..2c85370279d
--- /dev/null
+++ b/mail/clawsker/files/patch-clawsker
@@ -0,0 +1,11 @@
+--- clawsker.orig Mon Feb 4 23:58:45 2008
++++ clawsker Mon Feb 4 23:59:08 2008
+@@ -345,8 +345,6 @@
+ sub set_widget_hint() {
+ if ($SHOWHINTS) {
+ my ($wdgt, $hint) = @_;
+- $wdgt->set_tooltip_text ($hint);
+- $wdgt->set_has_tooltip (TRUE);
+ }
+ }
+
diff --git a/mail/clawsker/pkg-descr b/mail/clawsker/pkg-descr
new file mode 100644
index 00000000000..bc2a8b34958
--- /dev/null
+++ b/mail/clawsker/pkg-descr
@@ -0,0 +1,19 @@
+Clawsker is an applet to edit Claws Mail's hidden preferences.
+
+Claws Mail has a high number of configurable options and, in order to keep
+the binary small and fast, some of these preferences which are not widely
+used are not provided with a graphical interface for inspection and/or
+modification.
+
+Users wanting to edit such preferences had to face editing the configuration
+text files directly, now it is possible with a convenient GTK2 interface using
+Clawsker.
+
+Other features:
+
+ * Handling of all hidden preferences
+ * Fully internationalized interface using gettext
+ * Detection of running Claws Mail
+ * Support for alternate configuration directories
+
+WWW: http://www.claws-mail.org/clawsker