aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-05-09 15:16:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-05-09 15:16:38 +0800
commitad59b2c609ebebbfafc5ac2cc209f999f7485ebb (patch)
treec88af73f26eaca359c8c8621bda717b75996f5cf /mail
parent16d5b175bd96cc25fb436d96c09711ae899d2433 (diff)
downloadfreebsd-ports-graphics-ad59b2c609ebebbfafc5ac2cc209f999f7485ebb.tar.gz
freebsd-ports-graphics-ad59b2c609ebebbfafc5ac2cc209f999f7485ebb.tar.zst
freebsd-ports-graphics-ad59b2c609ebebbfafc5ac2cc209f999f7485ebb.zip
- Add p5-SES
Perl module of Amazon Simple Email Services WWW: http://aws.amazon.com/code/Amazon-SES/8945574369528337 PR: ports/156713 Submitted by: Stephon Chen <stephon@pixnet.tw>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-SES/Makefile40
-rw-r--r--mail/p5-SES/distinfo2
-rw-r--r--mail/p5-SES/pkg-descr10
4 files changed, 53 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 7b2c5c4b559..204fedf3095 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -447,6 +447,7 @@
SUBDIR += p5-POE-Filter-Transparent-SMTP
SUBDIR += p5-Parse-Syslog-Mail
SUBDIR += p5-Qmail-Envelope
+ SUBDIR += p5-SES
SUBDIR += p5-Sendmail-AccessDB
SUBDIR += p5-Sendmail-Milter
SUBDIR += p5-URI-imap
diff --git a/mail/p5-SES/Makefile b/mail/p5-SES/Makefile
new file mode 100644
index 00000000000..4c90f3a8813
--- /dev/null
+++ b/mail/p5-SES/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-SES
+# Date created: 2011-04-29
+# Whom: Stephon Chen <stephon@pixnet.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SES
+PORTVERSION= 1.00
+CATEGORIES= mail perl5
+MASTER_SITES= http://aws-catalog-download-files.s3.amazonaws.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= Amazon${PORTNAME}-2011-03-03
+
+MAINTAINER= stephon@pixnet.tw
+COMMENT= Perl module of Amazon Simple Email Services
+
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/bin
+
+PLIST_FILES= bin/ses-get-stats.pl \
+ bin/ses-send-email.pl \
+ bin/ses-verify-email-address.pl \
+ %%SITE_PERL%%/SES.pm
+
+SCRIPTS= ses-get-stats.pl ses-send-email.pl ses-verify-email-address.pl
+
+post-extract:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${SCRIPTS}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/SES.pm ${PREFIX}/${SITE_PERL_REL}/
+
+.include <bsd.port.mk>
diff --git a/mail/p5-SES/distinfo b/mail/p5-SES/distinfo
new file mode 100644
index 00000000000..ef577d9f47e
--- /dev/null
+++ b/mail/p5-SES/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AmazonSES-2011-03-03.zip) = 19ec217d018437b187a27e2103833a89ec9badd18bba10c2823166a643ea922f
+SIZE (AmazonSES-2011-03-03.zip) = 306054
diff --git a/mail/p5-SES/pkg-descr b/mail/p5-SES/pkg-descr
new file mode 100644
index 00000000000..108f6b88a81
--- /dev/null
+++ b/mail/p5-SES/pkg-descr
@@ -0,0 +1,10 @@
+Amazon Simple Email Service Scripts
+
+The Amazon SES Scripts zip archive contains the following Perl scripts:
+- ses-get-stats.pl: retrieves statistics about Amazon SES account usage.
+- ses-send-email.pl: send email using Amazon SES.
+- ses-verify-email-addresses.pl: verify email addresses to be used with
+ Amazon SES.
+- SES.pm: a module used by all of the above scripts.
+
+WWW: http://aws.amazon.com/code/Amazon-SES/8945574369528337