aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-06 04:59:34 +0800
committerpawel <pawel@FreeBSD.org>2014-06-06 04:59:34 +0800
commitbacbdd076e986c6621b19765afdfdaedc089b3f0 (patch)
treed06d246caaf991c3c643e7fa879d9f0165fb29f8 /mail
parent60eeb3bb89d21b08310bba7904bef365a0b89512 (diff)
downloadfreebsd-ports-graphics-bacbdd076e986c6621b19765afdfdaedc089b3f0.tar.gz
freebsd-ports-graphics-bacbdd076e986c6621b19765afdfdaedc089b3f0.tar.zst
freebsd-ports-graphics-bacbdd076e986c6621b19765afdfdaedc089b3f0.zip
- Add staging support
- Convert to new option framework - More precise BSD license - Use @sample for config file - Fix typo, remove Author tag from pkg-descr
Diffstat (limited to 'mail')
-rw-r--r--mail/proxsmtp/Makefile24
-rw-r--r--mail/proxsmtp/pkg-descr3
-rw-r--r--mail/proxsmtp/pkg-plist6
3 files changed, 11 insertions, 22 deletions
diff --git a/mail/proxsmtp/Makefile b/mail/proxsmtp/Makefile
index 977d85d8a70..637920aa224 100644
--- a/mail/proxsmtp/Makefile
+++ b/mail/proxsmtp/Makefile
@@ -3,13 +3,14 @@
PORTNAME= proxsmtp
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= http://thewalter.net/stef/software/proxsmtp/
MAINTAINER= ports@FreeBSD.org
COMMENT= Flexible SMTP filter which can act also as transparent proxy
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= gmake
GNU_CONFIGURE= yes
@@ -17,12 +18,10 @@ GNU_CONFIGURE= yes
USE_RC_SUBR= proxsmtpd
SUB_FILES= pkg-message
-MAN5= proxsmtpd.conf.5
-MAN8= proxsmtpd.8
-
PORTDOCS= ChangeLog NEWS README
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
'/^acx_pthread_flags/s|=.*|="${PTHREAD_LIBS}"|' \
@@ -30,17 +29,8 @@ post-patch:
post-install:
(cd ${WRKSRC}/doc && ${INSTALL_DATA} proxsmtpd.conf \
- ${PREFIX}/etc/proxsmtpd.conf-sample)
-.if !exists(${PREFIX}/etc/proxsmtpd.conf)
- (cd ${PREFIX}/etc && ${CP} -p proxsmtpd.conf-sample \
- ${PREFIX}/etc/proxsmtpd.conf)
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for docs in ${PORTDOCS}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${docs} ${DOCSDIR})
-.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/etc/proxsmtpd.conf.sample)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/mail/proxsmtp/pkg-descr b/mail/proxsmtp/pkg-descr
index 79fdef12afb..a2deadc2a13 100644
--- a/mail/proxsmtp/pkg-descr
+++ b/mail/proxsmtp/pkg-descr
@@ -1,8 +1,7 @@
ProxSMTP is a flexible tool that allows you to reject, change or log
-email based on arbitrary critera. It accepts SMTP connections and
+email based on arbitrary criteria. It accepts SMTP connections and
forwards the SMTP commands and responses to another SMTP server. You
need to be able to write the filtering scripts that integrate it with
your particular needs.
-Author: Nielsen <nielsen at memberwebs.com>
WWW: http://thewalter.net/stef/software/proxsmtp/
diff --git a/mail/proxsmtp/pkg-plist b/mail/proxsmtp/pkg-plist
index 8d357472d43..6f836070104 100644
--- a/mail/proxsmtp/pkg-plist
+++ b/mail/proxsmtp/pkg-plist
@@ -1,5 +1,5 @@
@unexec [ ! -f /var/run/proxsmtpd.pid ] || %%PREFIX%%/etc/rc.d/proxsmtpd.sh stop || true
-@unexec if cmp -s %D/etc/proxsmtpd.conf-sample %D/etc/proxsmtpd.conf; then rm -f %D/etc/proxsmtpd.conf; fi
-etc/proxsmtpd.conf-sample
-@exec if [ ! -f %D/etc/proxsmtpd.conf ] ; then cp -p %D/%F %B/proxsmtpd.conf; fi
+@sample etc/proxsmtpd.conf.sample
+man/man5/proxsmtpd.conf.5.gz
+man/man8/proxsmtpd.8.gz
sbin/proxsmtpd