aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2001-08-27 20:54:57 +0800
committernbm <nbm@FreeBSD.org>2001-08-27 20:54:57 +0800
commitbcacaec2e91821d23fb8bd8ee41eb93f4011dcfe (patch)
tree192034387cbf2bb6b742e6b36d39ac1e9c7c8f97 /mail
parent27611954ec826ed6265f9a9f90d929c2d773e651 (diff)
downloadfreebsd-ports-graphics-bcacaec2e91821d23fb8bd8ee41eb93f4011dcfe.tar.gz
freebsd-ports-graphics-bcacaec2e91821d23fb8bd8ee41eb93f4011dcfe.tar.zst
freebsd-ports-graphics-bcacaec2e91821d23fb8bd8ee41eb93f4011dcfe.zip
1) Correct a type in PLIST_SUB entry for authpam.
2) Enable dependencies properly for vpopmail 3) Add an option WITH_MYSQL for mysql authentication Submitted by: dirk (1)
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile14
-rw-r--r--mail/courier-imap/pkg-plist1
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 011676db000..203a11938f4 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -28,7 +28,6 @@ PLIST_SUB= OPENSSLFLAG="@comment "
CONFIGURE_ARGS= --without-authldap --with-authldaprc=filename \
--without-authshadow \
--without-authcram \
- --without-authmysql \
--sysconfdir=${PREFIX}/etc/courier-imap \
--with-userdb=${PREFIX}/etc/userdb \
--datadir=${PREFIX}/share/courier-imap \
@@ -36,14 +35,25 @@ CONFIGURE_ARGS= --without-authldap --with-authldaprc=filename \
--enable-workarounds-for-imap-client-bugs \
--disable-root-check
+VPOPMAILDIR?= ${LOCALBASE}/vpopmail
.if !defined(WITH_VPOPMAIL)
CONFIGURE_ARGS+= \
--without-authvchkpw
PLIST_SUB+= VPOPMAILFLAG="@comment "
.else
+BUILD_DEPENDS+= ${VPOPMAILDIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
PLIST_SUB+= VPOPMAILFLAG=""
.endif
+.if !defined(WITH_MYSQL)
+CONFIGURE_ARGS+= \
+ --without-authmysql \
+PLIST_SUB+= MYSQLFLAG="@comment "
+.else
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+PLIST_SUB+= MYSQLFLAG=""
+.endif
+
.if !defined(WITHOUT_PAM)
CONFIGURE_ARGS+= \
--with-authpam
@@ -51,7 +61,7 @@ PLIST_SUB+= PAMFLAG=""
.else
CONFIGURE_ARGS+= \
--without-authpam
-PLIST_SUB+= PAMFLAG="@comment"
+PLIST_SUB+= PAMFLAG="@comment "
.endif
MAN1= maildirmake.1
diff --git a/mail/courier-imap/pkg-plist b/mail/courier-imap/pkg-plist
index 7a9c9dc3dc2..76aa5a06efd 100644
--- a/mail/courier-imap/pkg-plist
+++ b/mail/courier-imap/pkg-plist
@@ -10,6 +10,7 @@ etc/courier-imap/pop3d.cnf.dist
etc/courier-imap/pop3d.dist
etc/courier-imap/quotawarnmsg.example
libexec/courier-imap/authlib/authcustom
+%%MYSQLFLAG%%libexec/courier-imap/authlib/authmysql
%%PAMFLAG%%libexec/courier-imap/authlib/authpam
libexec/courier-imap/authlib/authpwd
libexec/courier-imap/authlib/authuserdb