aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-04-30 01:05:19 +0800
committertruckman <truckman@FreeBSD.org>2015-04-30 01:05:19 +0800
commitee53b1a136430e97ea3c59ee9b01315c6c63b4fc (patch)
tree18e65f61c691f049a22d5258fba7ddb2cfce07d6 /mail
parent7487af19fcd57337adb0ac79efdff6165ce42d3f (diff)
downloadfreebsd-ports-graphics-ee53b1a136430e97ea3c59ee9b01315c6c63b4fc.tar.gz
freebsd-ports-graphics-ee53b1a136430e97ea3c59ee9b01315c6c63b4fc.tar.zst
freebsd-ports-graphics-ee53b1a136430e97ea3c59ee9b01315c6c63b4fc.zip
Remove USES=compiler:c++11-lib from mail/evolution. While it fixes
the build failure on FreeBSD 8 (and probably 9), the application fails to start because the base version of libstdc++ is loaded at runtime, which does not satify the requirements of webkit-gtk3. The reason is that evolution does not directly link to libstdc++, so the rpath added to it by USES=compiler:c++11-lib has no effect. The first shared library that links to libstdc++ belongs to evolution-data-server, which does not have USES=compiler:c++11-lib, which causes the base version of libstdc++ to be loaded. Unconditionally add USES=compiler:c++11-lib to databases/evolution-data-server. Adding the rpath to its shared libraries will cause the newer version of libstdc++ to be loaded when evolution starts and fix the runtime error on FreeBSD 8 and 9. For standard versions of FreeBSD 10 and higher on amd64 and i386, it is a no-op, so there is no harm in doing this. If FreeBSD 10 or higher is configured to build with base gcc and clang is not present, which is an option on amd64 and i386 and is mandatory on some tier 2 platforms that don't have clang support, then USES=compiler:c++11-lib is needed. PR: 199746 Differential Revision: https://reviews.freebsd.org/D2388 Reviewed by: kwm Approved by: mat (mentor) MFH: 2015Q2
Diffstat (limited to 'mail')
-rw-r--r--mail/evolution/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index cf0c75aea06..eea091e969e 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -4,7 +4,7 @@
PORTNAME= evolution
PORTVERSION= 3.12.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -107,11 +107,6 @@ CONFIGURE_ARGS+=--disable-contact-maps
.include <bsd.port.options.mk>
-# webkit-gtk3 needs this
-.if ${OSVERSION} < 1000000
-USES+= compiler:c++11-lib
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^plugins_standard_always/s/audio-inline//' \
-e 's|-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi|${KRB5_LIB}|g' \