aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-05 01:28:04 +0800
committerpav <pav@FreeBSD.org>2004-05-05 01:28:04 +0800
commitfe22f9e78a4f2e6dae48142392d884062c0e2dbb (patch)
tree55a1b4ca4e24a427fadeedf049ba6d660a55b201 /mail
parent0cd00eb4e58076b851460b231d036205fe982b5e (diff)
downloadfreebsd-ports-graphics-fe22f9e78a4f2e6dae48142392d884062c0e2dbb.tar.gz
freebsd-ports-graphics-fe22f9e78a4f2e6dae48142392d884062c0e2dbb.tar.zst
freebsd-ports-graphics-fe22f9e78a4f2e6dae48142392d884062c0e2dbb.zip
- Add option to build with db 4.2
- Clean up pkg-plist for optional options PR: ports/66214 Submitted by: Vivek Khera <vivek@khera.org> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-current/pkg-plist3
-rw-r--r--mail/postfix-current/scripts/configure.postfix31
2 files changed, 23 insertions, 11 deletions
diff --git a/mail/postfix-current/pkg-plist b/mail/postfix-current/pkg-plist
index 2dd0abfec27..be3c0df1026 100644
--- a/mail/postfix-current/pkg-plist
+++ b/mail/postfix-current/pkg-plist
@@ -22,8 +22,6 @@ etc/postfix/dist-header_checks
etc/postfix/dist-relocated
etc/postfix/dist-transport
etc/postfix/dist-virtual
-%%SUB_IPV6%%etc/postfix/dist-ipv6.cf
-%%SUB_TLS%%etc/postfix/dist-tls.cf
libexec/postfix/anvil
libexec/postfix/bounce
libexec/postfix/cleanup
@@ -93,6 +91,7 @@ bin/mailq
%%PORTDOCS%%%%DOCSDIR%%/FILTER_README.html
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.html
+%%PORTDOCS%%%%SUB_IPV6%%%%DOCSDIR%%/IPV6_README
%%PORTDOCS%%%%DOCSDIR%%/LDAP_README
%%PORTDOCS%%%%DOCSDIR%%/LDAP_README.html
%%PORTDOCS%%%%DOCSDIR%%/LINUX_README
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index 8e2e74cd1d1..6272423f427 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -29,6 +29,7 @@ IPv6TLS "IPv6 support with SSL and TLS (BROKEN)" "$status_IPv6TLS" \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" "$status_DB3" \
DB40 "Berkeley DB4.0 (required if SASL also built with DB4.0)" "$status_DB40" \
DB41 "Berkeley DB4.1 (required if SASL also built with DB4.1)" "$status_DB41" \
+DB42 "Berkeley DB4.2 (required if SASL also built with DB4.2)" "$status_DB42" \
MySQL "MySQL map lookups (choose version with WITH_MYSQL_VER)" "$status_MySQL" \
PgSQL "PostgreSQL v7.4 map lookups" "$status_PgSQL" \
PgSQL73 "PostgreSQL v7.3 map lookups" "$status_PgSQL73" \
@@ -114,8 +115,8 @@ while [ "$1" ]; do
SUB_TLS=""
;;
DB3)
- if [ X$DB40_SELECTED != "X" -o X$DB41_SELECTED != "X" ]; then
- /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40 and DB41 options." 5 60 > /dev/stderr
+ if [ "X$BDB_SELECTED" != "X" ]; then
+ /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40, DB41 and DB42 options." 5 60 > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
@@ -123,11 +124,11 @@ while [ "$1" ]; do
echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db3"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb3"
echo "DB_SUFFIX= +db3"
- DB3_SELECTED="YES"
+ BDB_SELECTED="3"
;;
DB40)
- if [ X$DB3_SELECTED != "X" -o X$DB41_SELECTED != "X" ]; then
- /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40 and DB41 options." 5 60 > /dev/stderr
+ if [ "X$BDB_SELECTED" != "X" ]; then
+ /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40, DB41 and DB42 options." 5 60 > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
@@ -135,11 +136,11 @@ while [ "$1" ]; do
echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db4"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb4"
echo "DB_SUFFIX= +db40"
- DB40_SELECTED="YES"
+ BDB_SELECTED="40"
;;
DB41)
- if [ X$DB3_SELECTED != "X" -o X$DB40_SELECTED != "X" ]; then
- /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40 and DB41 options." 5 60 > /dev/stderr
+ if [ "X$BDB_SELECTED" != "X" ]; then
+ /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40, DB41 and DB42 options." 5 60 > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
@@ -147,7 +148,19 @@ while [ "$1" ]; do
echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db41"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb41"
echo "DB_SUFFIX= +db41"
- DB41_SELECTED="YES"
+ BDB_SELECTED="41"
+ ;;
+ DB42)
+ if [ "X$BDB_SELECTED" != "X" ]; then
+ /usr/bin/dialog --msgbox "Select exactly one of the DB3, DB40, DB41 and DB42 options." 5 60 > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ fi
+ echo "LIB_DEPENDS+= db-4.2.2:\${PORTSDIR}/databases/db42"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db42"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib/db42/ -ldb"
+ echo "DB_SUFFIX= +db42"
+ BDB_SELECTED="42"
;;
MySQL)
echo "USE_MYSQL=YES"