aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-23 06:30:00 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-23 06:30:00 +0800
commitff2d61e6e5bd222b15efe32b587d19056c21354c (patch)
tree461793f76db7668ca1f2e39302b1cad79b8f4f9e /mail
parent1865563f3fe71662ac098e2895b6a03138371dc1 (diff)
downloadfreebsd-ports-graphics-ff2d61e6e5bd222b15efe32b587d19056c21354c.tar.gz
freebsd-ports-graphics-ff2d61e6e5bd222b15efe32b587d19056c21354c.tar.zst
freebsd-ports-graphics-ff2d61e6e5bd222b15efe32b587d19056c21354c.zip
Add sendok, a command line utility for generating qmail email addresses with
timed cookies. PR: 87824 Submitted by: Zak Johnson <zakj@nox.cx>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/sendok/Makefile33
-rw-r--r--mail/sendok/distinfo2
-rw-r--r--mail/sendok/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 57d41f2e36b..b7e28b65f04 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -466,6 +466,7 @@
SUBDIR += sendmail
SUBDIR += sendmail-ldap
SUBDIR += sendmail-sasl
+ SUBDIR += sendok
SUBDIR += sentinel
SUBDIR += serialmail
SUBDIR += sid-milter
diff --git a/mail/sendok/Makefile b/mail/sendok/Makefile
new file mode 100644
index 00000000000..4f577e3dc8e
--- /dev/null
+++ b/mail/sendok/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sendok
+# Date created: 18 October 2005
+# Whom: Zak Johnson <zakj@nox.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sendok
+PORTVERSION= 0.9.1
+CATEGORIES= mail
+MASTER_SITES= http://peff.net/sendok/ \
+ http://www.cs.virginia.edu/~jrk3g/sendok/
+
+MAINTAINER= zakj@nox.cx
+COMMENT= Generates qmail email addresses with timed cookies
+
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+PLIST_FILES= bin/sendok-check bin/sendok-create
+
+ALL_TARGET= it
+QMAIL_DIR?= /var/qmail
+
+post-patch:
+ @${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
+ @${ECHO_CMD} ${CC} ${CFLAGS} >${WRKSRC}/conf-cc
+
+do-install:
+.for f in sendok-check sendok-create
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/sendok/distinfo b/mail/sendok/distinfo
new file mode 100644
index 00000000000..e8f5466e89b
--- /dev/null
+++ b/mail/sendok/distinfo
@@ -0,0 +1,2 @@
+MD5 (sendok-0.9.1.tar.gz) = c40c6fb25a0bf42cf4c6d1fcdbc4f535
+SIZE (sendok-0.9.1.tar.gz) = 14988
diff --git a/mail/sendok/pkg-descr b/mail/sendok/pkg-descr
new file mode 100644
index 00000000000..d8eda46a84f
--- /dev/null
+++ b/mail/sendok/pkg-descr
@@ -0,0 +1,6 @@
+sendok is a simple program to generate qmail email addresses with timed cookies
+in them. That is, you can give someone a generated address that will accept
+mail from a given sender for a given time period. The address contains a
+cryptographic hash so that no per-address local data needs to be stored.
+
+WWW: http://peff.net/sendok/