aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-10-31 14:20:44 +0800
committerdinoex <dinoex@FreeBSD.org>2006-10-31 14:20:44 +0800
commit12559a15dcb5d7899619bd0b0b1d8fdd0d55307e (patch)
tree9a8466a51361bfa307726edea1474291420da0e7 /math/Makefile
parentb0866961317dda0a897b28e5f7ed1869c2f54a56 (diff)
downloadfreebsd-ports-graphics-12559a15dcb5d7899619bd0b0b1d8fdd0d55307e.tar.gz
freebsd-ports-graphics-12559a15dcb5d7899619bd0b0b1d8fdd0d55307e.tar.zst
freebsd-ports-graphics-12559a15dcb5d7899619bd0b0b1d8fdd0d55307e.zip
MathArray is a general library of classes for performing mathematical
operations on arrays (vectors, matrices, etc) of values. It can operate on any standard 'C' number type plus numbers of complex type. MathArray is implemented using a "class cluster" concept, allowing one to perform mathematical calculations on a number without necessarily being aware of what type (class) of number is being operated on. MathArray knows implicitly what types of operations can be performed on what types of numbers and will automatically cast itself to the correct number type representation to handle the specific operation. Standard operations include addition, scalar and matrix multiplication and logical operations. Mathematical operations in the standard C math library are also supported, as well as user-defined functions. MathArray also does much more. Arrays can be manipulated, transposed and concatenated. One can extract subarrays or include subarrays within larger arrays.
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 1816684014b..0ac4e03cea5 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -133,6 +133,7 @@
SUBDIR += linux-relview
SUBDIR += lp_solve
SUBDIR += ltl
+ SUBDIR += matharray
SUBDIR += mathomatic
SUBDIR += matrix
SUBDIR += maxima