aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-05-04 05:10:26 +0800
committerthierry <thierry@FreeBSD.org>2006-05-04 05:10:26 +0800
commitf7d61ab482e927f93c19bc1385d04bfa8e1b6e86 (patch)
tree06f8dc16d265d0bd86e41508442605156c992e5b /math/Makefile
parentb1308ce05ffc7b95897ace8aff972fe1ae822351 (diff)
downloadfreebsd-ports-graphics-f7d61ab482e927f93c19bc1385d04bfa8e1b6e86.tar.gz
freebsd-ports-graphics-f7d61ab482e927f93c19bc1385d04bfa8e1b6e86.tar.zst
freebsd-ports-graphics-f7d61ab482e927f93c19bc1385d04bfa8e1b6e86.zip
Before a calculation can be performed on a parallel computer, it must first be
decomposed into tasks which are assigned to different processors. Efficient use of the machine requires that each processor have about the same amount of work to do and that the quantity of interprocessor communication is kept small. Finding an optimal decomposition is provably hard, but due to its practical importance, a great deal of effort has been devoted to developing heuristics for this problem. The decomposition problem can be addressed in terms of graph partitioning. Rob Leland and I have developed a variety of algorithms for graph partitioning and implemented them into a package we call Chaco. The code is being used at most of the major parallel computing centers around the world to simplify the development of parallel applications, and to ensure that high performance is obtained. Chaco has contributed to a wide variety of computational studies including investigation of the molecular structure of liquid crystals, evaluating the design of a chemical vapor deposition reactor and modeling automobile collisions. WWW: http://www.cs.sandia.gov/~bahendr/chaco.html Note: this port includes a patch provided by Walter Landry for use within MBDyn PR: ports/96699 Submitted by: Pedro Giffuni <giffunip (at) asme.org>
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d0357cb7c53..dfbb321058b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -31,6 +31,7 @@
SUBDIR += calctool
SUBDIR += ccmath
SUBDIR += cgal
+ SUBDIR += chaco
SUBDIR += chryzodus
SUBDIR += clarence
SUBDIR += cln