aboutsummaryrefslogtreecommitdiffstats
path: root/math/R
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 22:44:45 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 22:44:45 +0800
commitfdf50cce0bd0f2ad6f9c586831195764389a0a49 (patch)
tree69086a9df5346876d7f5af81a7b85d6b045b446a /math/R
parentf6d163e564a838d18330567f4bc9418170407296 (diff)
downloadfreebsd-ports-graphics-fdf50cce0bd0f2ad6f9c586831195764389a0a49.tar.gz
freebsd-ports-graphics-fdf50cce0bd0f2ad6f9c586831195764389a0a49.tar.zst
freebsd-ports-graphics-fdf50cce0bd0f2ad6f9c586831195764389a0a49.zip
Support stage
Strip libR.a
Diffstat (limited to 'math/R')
-rw-r--r--math/R/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 9a47176b38d..beb7b72248c 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -71,7 +71,6 @@ OPTIONS_DEFAULT+= ICU PCRE_PORT THREADS
.if !defined(LIBR_SLAVEPORT)
RUN_DEPENDS+= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
USE_LDCONFIG= ${PREFIX}/lib/R/lib
-NO_STAGE= yes
#now only used to build the R.1 manpage:
USES+= perl5
USE_PERL5= build
@@ -351,12 +350,12 @@ do-build:
${MAKE_ARGS} Makefile Makedeps libR.a)
do-install:
- @${MKDIR} ${PREFIX}/lib/R/lib
- @${INSTALL_DATA} ${WRKSRC}/src/main/libR.a ${PREFIX}/lib/R/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/R/lib
+ @${INSTALL_LIB} ${WRKSRC}/src/main/libR.a ${STAGEDIR}${PREFIX}/lib/R/lib
.else # LIBR_SLAVEPORT
-pre-configure-script:
+pre-configure:
@${FIND} ${WRKSRC} \( -name '*.orig' -o -name '*.bak' \) -delete
check regression-test test: build