aboutsummaryrefslogtreecommitdiffstats
path: root/math/glpk/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2008-02-08 23:07:22 +0800
committerdemon <demon@FreeBSD.org>2008-02-08 23:07:22 +0800
commit72c23d87111cecc66f8e60fa18fc522602acbad2 (patch)
tree267874cf5e93e51e665f6a68867c2d2e32771212 /math/glpk/Makefile
parent44cadac72f7d990408748d9942bf30d5c4fee547 (diff)
downloadfreebsd-ports-graphics-72c23d87111cecc66f8e60fa18fc522602acbad2.tar.gz
freebsd-ports-graphics-72c23d87111cecc66f8e60fa18fc522602acbad2.tar.zst
freebsd-ports-graphics-72c23d87111cecc66f8e60fa18fc522602acbad2.zip
Update to 4.25.
Install more headers. PR: 119662 Submitted by: bf <bf2006a@yahoo.com>
Diffstat (limited to 'math/glpk/Makefile')
-rw-r--r--math/glpk/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index 289c28bd853..0705112a004 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glpk
-PORTVERSION= 4.24
+PORTVERSION= 4.25
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glpk
@@ -17,26 +17,23 @@ COMMENT= A GNU Linear Programming Kit
LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
USE_LDCONFIG= yes
CFLAGS+= -trigraphs
-
-GMPL_H= glpavl.h glpdmp.h glplib.h glpmpl.h glprng.h glpstd.h
-GMPLDIR= ${LOCALBASE}/include/gmpl
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.if !defined(NOPORTDOCS)
-PORTDOCS= bench.txt bench1.txt glpk.ps glpk_faq.txt gmpl.ps opb.txt
+PORTDOCS= bench.txt bench1.txt glpk.ps glpk_faq.txt gmpl.ps \
+ gomory.djvu opb.txt
.endif
post-install:
- @${MKDIR} ${GMPLDIR}
- for incfile in ${GMPL_H} ; do \
- ${INSTALL_DATA} ${WRKSRC}/include/$${incfile} ${GMPLDIR} ; \
- done
+ @${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/
.if !defined(NOPORTDOCS)
+ @${CP} ${WRKSRC}/doc/memo/gomory.djvu ${WRKSRC}/doc/
@${MKDIR} ${DOCSDIR}
for docfile in ${PORTDOCS} ; do \
${INSTALL_MAN} ${WRKSRC}/doc/$${docfile} ${DOCSDIR} ; \