aboutsummaryrefslogtreecommitdiffstats
path: root/math/gotoblas
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2011-10-06 16:45:15 +0800
committermaho <maho@FreeBSD.org>2011-10-06 16:45:15 +0800
commit396ab079c9a1083c49d337beff8338b19506d861 (patch)
tree744a89ba0df8d3bd6dcbce9cd25ce41cbe1f9004 /math/gotoblas
parentfd0d65181c45d1ff458253f7166377371cbd5b1b (diff)
downloadfreebsd-ports-graphics-396ab079c9a1083c49d337beff8338b19506d861.tar.gz
freebsd-ports-graphics-396ab079c9a1083c49d337beff8338b19506d861.tar.zst
freebsd-ports-graphics-396ab079c9a1083c49d337beff8338b19506d861.zip
Fix build when gcc other than gcc46 exists.
PR: 161273 Submitted by: Oliver Hartmann <ohartman@zedat.fu-berlin.de>
Diffstat (limited to 'math/gotoblas')
-rw-r--r--math/gotoblas/Makefile2
-rw-r--r--math/gotoblas/files/patch-Makefile.system3
2 files changed, 4 insertions, 1 deletions
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 1b30bd106b9..407f132f0d5 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -100,6 +100,8 @@ post-patch:
${WRKSRC}/lapack/laswp/Makefile \
${WRKSRC}/reference/Makefile
${REINPLACE_CMD} -e "s+(ARCH)+(ARCH_)+" \
+ -e 's+%%LOCALBASE%%+${LOCALBASE}+' \
+ -e 's+%%_GCC_BUILD_DEPENDS%%+${_GCC_BUILD_DEPENDS}+' \
-e 's+$$(CROSS_SUFFIX)+${LOCALBASE}/bin/+' \
${WRKSRC}/Makefile.system
.if defined(WITH_OPENMP)
diff --git a/math/gotoblas/files/patch-Makefile.system b/math/gotoblas/files/patch-Makefile.system
index fba46a791a1..78bc1453570 100644
--- a/math/gotoblas/files/patch-Makefile.system
+++ b/math/gotoblas/files/patch-Makefile.system
@@ -1,11 +1,12 @@
--- Makefile.system.orig 2010-01-28 15:11:08.000000000 -0500
+++ Makefile.system 2011-09-05 12:30:26.000000000 -0400
-@@ -93,6 +93,10 @@
+@@ -93,6 +93,11 @@
EXTRALIB += -lm
endif
+ifeq ($(OSNAME), FreeBSD)
+EXTRALIB += -lm
++FCOMMON_OPT += -Wl,-rpath=%%LOCALBASE%%/lib/%%_GCC_BUILD_DEPENDS%%
+endif
+
ifeq ($(OSNAME), AIX)