aboutsummaryrefslogtreecommitdiffstats
path: root/math/mpfr/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-08-29 22:00:54 +0800
committerale <ale@FreeBSD.org>2005-08-29 22:00:54 +0800
commit762d0aef958103b1d9672f30be6329fec746a42d (patch)
tree7dedc0a51bad945608ff6f72f5060f7484824529 /math/mpfr/Makefile
parentb34ec410a7ae5d1de7b05a69db09caad3cd3a5cc (diff)
downloadfreebsd-ports-graphics-762d0aef958103b1d9672f30be6329fec746a42d.tar.gz
freebsd-ports-graphics-762d0aef958103b1d9672f30be6329fec746a42d.tar.zst
freebsd-ports-graphics-762d0aef958103b1d9672f30be6329fec746a42d.zip
Add mpfr 2.1.2, a library for multiple-precision floating-point
computations. PR: ports/84724 Submitted by: Steven G. Kargl <kargl@troutmask.apl.washington.edu>
Diffstat (limited to 'math/mpfr/Makefile')
-rw-r--r--math/mpfr/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
new file mode 100644
index 00000000000..6bdd68d3048
--- /dev/null
+++ b/math/mpfr/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mpfr
+# Date created: 28 Aug 2005
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpfr
+PORTVERSION= 2.1.2
+CATEGORIES= math devel
+MASTER_SITES= http://www.mpfr.org/mpfr-current/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A library for multiple-precision floating-point computations
+
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
+
+INFO= mpfr
+
+.include <bsd.port.mk>