aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-gsl/Makefile
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2016-11-26 06:06:18 +0800
committerstephen <stephen@FreeBSD.org>2016-11-26 06:06:18 +0800
commit8c28337cb981f82756ace007b1cf06aef7356ba7 (patch)
treeb56fc6f78ace8ee55bc157d406c4881ca40d7e02 /math/octave-forge-gsl/Makefile
parent5ebb08b847ae4db7010dd0638e4c32691ddb7751 (diff)
downloadfreebsd-ports-graphics-8c28337cb981f82756ace007b1cf06aef7356ba7.tar.gz
freebsd-ports-graphics-8c28337cb981f82756ace007b1cf06aef7356ba7.tar.zst
freebsd-ports-graphics-8c28337cb981f82756ace007b1cf06aef7356ba7.zip
- Update to 2.0.0.
Diffstat (limited to 'math/octave-forge-gsl/Makefile')
-rw-r--r--math/octave-forge-gsl/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index 5b5b4a996b6..875f709fb88 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -2,25 +2,29 @@
# $FreeBSD$
PORTNAME= octave-forge-gsl
-PORTVERSION= 1.0.8
-PORTREVISION= 17
+PORTVERSION= 2.0.0
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
LIB_DEPENDS= libgsl.so:math/gsl
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= HOME=${WRKSRC}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
-post-patch:
- @${REINPLACE_CMD} s+/bin/bash+${LOCALBASE}/bin/bash+g ${WRKSRC}/src/config*
+GNU_CONFIGURE= yes
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
.include <bsd.port.mk>