aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-09-03 05:59:18 +0800
committerthierry <thierry@FreeBSD.org>2006-09-03 05:59:18 +0800
commit7546bb46a6dc09d69050721bf7a92ada32a0a8c0 (patch)
treefdd577cdd679a171d689c861db405fa6d2d8631d /math/petsc/Makefile
parent7fb927beb3420e2213b0cfcefeeca2e3d77251a4 (diff)
downloadfreebsd-ports-graphics-7546bb46a6dc09d69050721bf7a92ada32a0a8c0.tar.gz
freebsd-ports-graphics-7546bb46a6dc09d69050721bf7a92ada32a0a8c0.tar.zst
freebsd-ports-graphics-7546bb46a6dc09d69050721bf7a92ada32a0a8c0.zip
Upgrade to PETSc 2.3.2.
There are no major interface changes, the minor changes are listed at <http://www-unix.mcs.anl.gov/petsc/petsc-as/documentation/changes/232.html>
Diffstat (limited to 'math/petsc/Makefile')
-rw-r--r--math/petsc/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index f0cd01e978a..4d9a0772bcd 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= petsc
-DISTVERSION= 2.3.1-p16
-PORTREVISION= 1
+DISTVERSION= 2.3.2-p0
PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
@@ -38,7 +37,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.if !defined(WITHOUT_X11)
USE_XLIB= yes
CONFIGURE_ARGS+= --with-x-include=${X11BASE}/include \
- --with-x-library=${X11BASE}/lib/libX11.so
+ --with-x-lib=${X11BASE}/lib/libX11.so
.endif
FFLAGS?= -O2
@@ -238,6 +237,14 @@ pre-configure:
@${REINPLACE_CMD} -e "s|/bin/ksh|${LOCALBASE}/bin/ksh93|" \
${WRKSRC}/bin/popup
@${RM} ${WRKSRC}/bin/popup.bak
+.if defined(PACKAGE_BUILDING)
+ @${REINPLACE_CMD} -e "s|%%PACKAGE%%exit 1; ||" \
+ -e "s|%%PACKAGE%%sys.exit(3)||" \
+ ${WRKSRC}/makefile ${WRKSRC}/config/configure.py
+.else
+ @${REINPLACE_CMD} -e "s|%%PACKAGE%%||" \
+ ${WRKSRC}/makefile ${WRKSRC}/config/configure.py
+.endif
post-install:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bin