aboutsummaryrefslogtreecommitdiffstats
path: root/math/scigraphica/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-07-04 22:46:46 +0800
committersobomax <sobomax@FreeBSD.org>2001-07-04 22:46:46 +0800
commit34802c500c9c28cb35e7dd41aee48f257495de36 (patch)
tree4415d52a7c449b06ec5a732767c80da291183f74 /math/scigraphica/files
parent2650fdba0ee0cdacb437c52e71eceb6a7566b28d (diff)
downloadfreebsd-ports-graphics-34802c500c9c28cb35e7dd41aee48f257495de36.tar.gz
freebsd-ports-graphics-34802c500c9c28cb35e7dd41aee48f257495de36.tar.zst
freebsd-ports-graphics-34802c500c9c28cb35e7dd41aee48f257495de36.zip
Update to 0.7.0.
Submitted by: AMAKAWA Shuhei <sa264@cam.ac.uk>
Diffstat (limited to 'math/scigraphica/files')
-rw-r--r--math/scigraphica/files/patch-ac14
-rw-r--r--math/scigraphica/files/patch-ae11
-rw-r--r--math/scigraphica/files/patch-src::Makefile.in14
-rw-r--r--math/scigraphica/files/patch-src::sg_project_menu.c17
4 files changed, 31 insertions, 25 deletions
diff --git a/math/scigraphica/files/patch-ac b/math/scigraphica/files/patch-ac
deleted file mode 100644
index 47910ed51b2..00000000000
--- a/math/scigraphica/files/patch-ac
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Sun Mar 11 12:53:57 2001
-+++ configure Sun Mar 11 12:55:30 2001
-@@ -3708,7 +3708,7 @@
- PY_VVERSION=`python -c 'import sys ; print sys.version[0:5]'`
- if test -f $PY_PREFIX/include/python$PY_VERSION/Python.h; then
- PY_LIBS="python$PY_VERSION"
-- PY_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
-+ PY_LIB_LOC="-pthread -L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
- array_loc=`find $PY_PREFIX/include/python$PY_VERSION/ -name arrayobject.h | sed s/arrayobject\.h//`
- echo arrayobject.h location: $array_loc
- PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
diff --git a/math/scigraphica/files/patch-ae b/math/scigraphica/files/patch-ae
deleted file mode 100644
index 05f95ae7d50..00000000000
--- a/math/scigraphica/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/Makefile.in 2000/08/31 08:26:13 1.1
-+++ examples/Makefile.in 2000/08/31 08:26:37
-@@ -114,7 +114,7 @@
- EXTRA_DIST = $(EXAMPLES)
-
-
--Examplesdir = $(datadir)/examples
-+Examplesdir = $(datadir)/examples/sg
-
- Examples_DATA = $(EXAMPLES)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/math/scigraphica/files/patch-src::Makefile.in b/math/scigraphica/files/patch-src::Makefile.in
new file mode 100644
index 00000000000..4b43c972e05
--- /dev/null
+++ b/math/scigraphica/files/patch-src::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile.in 2001/07/04 14:09:22 1.1
++++ src/Makefile.in 2001/07/04 14:10:08
+@@ -139,7 +139,7 @@
+ INCLUDES = -Ipython $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS) $(XML_CFLAGS) $(PY_CFLAGS) $(BONOBO_CFLAGS) $(OAF_CFLAGS)
+
+
+-sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
++sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -pthread -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
+
+
+ LIBS = @LIBS@
diff --git a/math/scigraphica/files/patch-src::sg_project_menu.c b/math/scigraphica/files/patch-src::sg_project_menu.c
new file mode 100644
index 00000000000..f6401d2dafc
--- /dev/null
+++ b/math/scigraphica/files/patch-src::sg_project_menu.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- src/sg_project_menu.c 2001/07/04 14:27:49 1.1
++++ src/sg_project_menu.c 2001/07/04 14:28:27
+@@ -554,9 +554,9 @@
+ }
+
+ if ( getenv("SG_ROOT") )
+- g_snprintf(path, 250, "%s/share/scigraphica/examples/%s", getenv("SG_ROOT"), (gchar*)data);
++ g_snprintf(path, 250, "%s/share/gnome/scigraphica/examples/%s", getenv("SG_ROOT"), (gchar*)data);
+ else
+- g_snprintf(path, 250, SG_ROOT "/share/scigraphica/examples/%s", (gchar*)data);
++ g_snprintf(path, 250, SG_ROOT "/share/gnome/scigraphica/examples/%s", (gchar*)data);
+
+ sg_project_close();
+ sg_project_new();