aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk43/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1999-06-01 21:16:47 +0800
committertg <tg@FreeBSD.org>1999-06-01 21:16:47 +0800
commit4b87fe0052775de8b60e48548416f4c1a5a72296 (patch)
tree4f178bae494070d0cf7eeaddd497b9d856e71378 /math/vtk43/Makefile
parent65bcc7096626debf43f35313cab321f410e85cc7 (diff)
downloadfreebsd-ports-graphics-4b87fe0052775de8b60e48548416f4c1a5a72296.tar.gz
freebsd-ports-graphics-4b87fe0052775de8b60e48548416f4c1a5a72296.tar.zst
freebsd-ports-graphics-4b87fe0052775de8b60e48548416f4c1a5a72296.zip
Re-import vtk into "math", this is where all the other
data visualization tools are.
Diffstat (limited to 'math/vtk43/Makefile')
-rw-r--r--math/vtk43/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/vtk43/Makefile b/math/vtk43/Makefile
new file mode 100644
index 00000000000..3ba8768cd17
--- /dev/null
+++ b/math/vtk43/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: vtk
+# Version required: 2.3
+# Date created: 24 Nov 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= vtk23unix
+PKGNAME= vtk-2.3
+CATEGORIES= math
+MASTER_SITES= ftp://vtk.scorec.rpi.edu/pub/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3 \
+ tk80.1:${PORTSDIR}/x11-toolkits/tk80
+
+WRKSRC= $(WRKDIR)/vtk
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CXXFLAGS="${CFLAGS}"
+
+post-install:
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>