aboutsummaryrefslogtreecommitdiffstats
path: root/math/xgfe/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-04-19 10:30:02 +0800
committerwill <will@FreeBSD.org>2002-04-19 10:30:02 +0800
commit4c52c9067b06ff76694d44e2bd5819fc06e974fe (patch)
tree8ea2fec29854e5717863bf5e5bf1d1b05d97cefe /math/xgfe/files
parent9d74629523b0c2fe5f02ba4bc3f37c73af058448 (diff)
downloadfreebsd-ports-graphics-4c52c9067b06ff76694d44e2bd5819fc06e974fe.tar.gz
freebsd-ports-graphics-4c52c9067b06ff76694d44e2bd5819fc06e974fe.tar.zst
freebsd-ports-graphics-4c52c9067b06ff76694d44e2bd5819fc06e974fe.zip
Say goodbye to Qt 1.x and all of its dependents. The one port I found
which probably isn't supposed to be removed is misc/instant-workstation, which had a dependency on audio/xamp (being removed), so I removed that dependency and bumped PORTREVISION. All other ports are real dependents upon Qt 1.x, including KDE 1.x stuff. Code in bsd.kde.mk supporting these ports is also removed or adjusted. Also, some adjustments made to accomodate Qt3/KDE3 ports, which will be committed Real Soon Now (TM), pending repo-copies. This commit made in impending view of Qt3/KDE3 entering ports tree.
Diffstat (limited to 'math/xgfe/files')
-rw-r--r--math/xgfe/files/patch-aa42
-rw-r--r--math/xgfe/files/patch-ab28
-rw-r--r--math/xgfe/files/patch-ac12
3 files changed, 0 insertions, 82 deletions
diff --git a/math/xgfe/files/patch-aa b/math/xgfe/files/patch-aa
deleted file mode 100644
index ef42d0c8c58..00000000000
--- a/math/xgfe/files/patch-aa
+++ /dev/null
@@ -1,42 +0,0 @@
---- Makefile.freebsd-gcc.orig Sat Mar 21 21:04:38 1998
-+++ Makefile.freebsd-gcc Fri Apr 10 13:28:16 1998
-@@ -7,12 +7,13 @@
-
- ####### Compiler, tools and options
-
--CC = gcc
--CFLAGS = -Wall -W -O2 -fno-strength-reduce
--INCPATH = -I$(QTDIR)/include
--LINK = gcc
-+#CC = gcc
-+#CFLAGS = -Wall -W -O2 -fno-strength-reduce
-+QTDIR = $(X11BASE)
-+INCPATH = -I$(X11BASE)/include/X11/qt
-+LINK = $(CXX)
- LFLAGS =
--LIBS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -lX11
-+LIBS = -L$(QTDIR)/lib -lqt -L$(X11BASE)/lib -lX11
- MOC = moc
-
- ####### Files
-@@ -161,16 +162,16 @@
- .SUFFIXES: .cpp .cxx .cc .C .c
-
- .cpp.o:
-- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
-+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
-
- .cxx.o:
-- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
-+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
-
- .cc.o:
-- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
-+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
-
- .C.o:
-- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
-+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
-
- .c.o:
- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
diff --git a/math/xgfe/files/patch-ab b/math/xgfe/files/patch-ab
deleted file mode 100644
index 2ecb111c349..00000000000
--- a/math/xgfe/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.common.orig Tue May 26 22:09:43 1998
-+++ Makefile.common Wed Jun 10 15:00:13 1998
-@@ -2,8 +2,8 @@
-
- # modify starting here
-
--INSTALL_BIN = /usr/local/bin
--INSTALL_DOC = /usr/local/doc/xgfe-$(VERSION)
-+INSTALL_BIN = $(PREFIX)/bin
-+INSTALL_DOC = $(PREFIX)/share/doc/xgfe
- STATIC_TARGET = xgfe-static
-
- # end modifications
-@@ -15,10 +15,11 @@
- strip $(STATIC_TARGET)
-
- install:
-- cp $(TARGET) $(INSTALL_BIN)
-+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(INSTALL_BIN)
-+.if !defined(NOPORTDOCS)
- mkdir -p $(INSTALL_DOC)
-- cp ../doc/* $(INSTALL_DOC)/
-- strip $(INSTALL_BIN)/$(TARGET)
-+ $(BSD_INSTALL_DATA) ../doc/* $(INSTALL_DOC)/
-+.endif
-
- uninstall:
- rm $(INSTALL_BIN)$(TARGET)
diff --git a/math/xgfe/files/patch-ac b/math/xgfe/files/patch-ac
deleted file mode 100644
index 0bfa74ad7fd..00000000000
--- a/math/xgfe/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- xgfeMainData.cpp.orig Sun Jun 7 14:39:29 1998
-+++ xgfeMainData.cpp Sat Feb 12 05:00:10 2000
-@@ -34,6 +34,9 @@
- #include <qpushbt.h>
- #include <qlayout.h>
-
-+#define QColor(i) (QColor)(i)
-+#define QRgb(i) (QRgb)(i)
-+
- xgfeMainData::xgfeMainData
- (
- QWidget* parent = 0,