aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-05-16 18:44:03 +0800
committerdemon <demon@FreeBSD.org>2014-05-16 18:44:03 +0800
commit206612fc8b96ad82b2ccf653d9ee73bcebfa1351 (patch)
tree9aea4e6fd5e492a5e8db93071f3ddf0069dc182a /math
parent877c5ce5b7e14301a1724395f1b17944828e4b5b (diff)
downloadfreebsd-ports-graphics-206612fc8b96ad82b2ccf653d9ee73bcebfa1351.tar.gz
freebsd-ports-graphics-206612fc8b96ad82b2ccf653d9ee73bcebfa1351.tar.zst
freebsd-ports-graphics-206612fc8b96ad82b2ccf653d9ee73bcebfa1351.zip
Respect CC/CFLAGS; add missing bison build dep.
Diffstat (limited to 'math')
-rw-r--r--math/foma/Makefile2
-rw-r--r--math/foma/files/patch-Makefile20
2 files changed, 21 insertions, 1 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
index 215d021c54f..62b41ea6770 100644
--- a/math/foma/Makefile
+++ b/math/foma/Makefile
@@ -11,7 +11,7 @@ COMMENT= A toolkit for constructing finite-state automata and transducers
LICENSE= GPLv2
-USES= gmake
+USES= bison gmake
USE_GCC= yes
USE_LDCONFIG= yes
diff --git a/math/foma/files/patch-Makefile b/math/foma/files/patch-Makefile
new file mode 100644
index 00000000000..94dfe4194f5
--- /dev/null
+++ b/math/foma/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2012-11-17 16:21:50.000000000 +0400
++++ Makefile 2014-05-16 14:41:24.000000000 +0400
+@@ -5,7 +5,7 @@
+ includedir = $(prefix)/include
+
+ VERSION = 0.9.17
+-CC = gcc
++CC ?= gcc
+ RANLIB = ranlib
+ YACC = bison -d -t -v
+ LEX = flex -8
+@@ -15,7 +15,7 @@
+ RM = /bin/rm -f
+ LDFLAGS = -lreadline -lz -ltermcap
+ FLOOKUPLDFLAGS = libfoma.a -lz
+-CFLAGS = -O3 -Wall -D_GNU_SOURCE -std=c99 -fvisibility=hidden -fPIC
++CFLAGS += -Wall -D_GNU_SOURCE -std=c99 -fvisibility=hidden -fPIC
+ FOMAOBJS = foma.o stack.o iface.o lex.interface.o
+ LIBOBJS = int_stack.o define.o determinize.o apply.o rewrite.o lexcread.o topsort.o flags.o minimize.o reverse.o extract.o sigma.o io.o structures.o constructions.o coaccessible.o utf8.o spelling.o dynarray.o mem.o stringhash.o trie.o lex.lexc.o lex.yy.o lex.cmatrix.o regex.tab.o
+