aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-29 04:41:23 +0800
committerswills <swills@FreeBSD.org>2014-03-29 04:41:23 +0800
commit36c55fe185ae176b8a89dea6c2eaa587cc0e0459 (patch)
treef53dc2663f8c94eee28cf416a87464b0963a45c7 /math
parent897e00e3a413512df208154beb03025834da29ee (diff)
downloadfreebsd-ports-graphics-36c55fe185ae176b8a89dea6c2eaa587cc0e0459.tar.gz
freebsd-ports-graphics-36c55fe185ae176b8a89dea6c2eaa587cc0e0459.tar.zst
freebsd-ports-graphics-36c55fe185ae176b8a89dea6c2eaa587cc0e0459.zip
- Avoid calling make while building
Requested by: marino
Diffstat (limited to 'math')
-rw-r--r--math/ruby-fftw3/Makefile7
-rw-r--r--math/rubygem-narray/Makefile4
-rw-r--r--math/rubygem-narray/Makefile.version1
3 files changed, 7 insertions, 5 deletions
diff --git a/math/ruby-fftw3/Makefile b/math/ruby-fftw3/Makefile
index 21bacab63f6..e11eed3f973 100644
--- a/math/ruby-fftw3/Makefile
+++ b/math/ruby-fftw3/Makefile
@@ -25,10 +25,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_NARRAY_VERSION!= ${MAKE} -C ${PORTSDIR}/math/rubygem-narray -V PORTVERSION
-RUBY_NARRAY_PKGNAME= narray-${RUBY_NARRAY_VERSION}
-
-CONFIGURE_ARGS+= --with-narray-include=${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/${RUBY_NARRAY_PKGNAME}/
+CONFIGURE_ARGS+= --with-narray-include=${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/narray-${NARRAY_VERSION}/
DOCS= LICENSE.txt doc/*
@@ -38,4 +35,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
+.include "${.CURDIR}/../rubygem-narray/Makefile.version"
+
.include <bsd.port.mk>
diff --git a/math/rubygem-narray/Makefile b/math/rubygem-narray/Makefile
index 3c8616ea091..972031ba6c1 100644
--- a/math/rubygem-narray/Makefile
+++ b/math/rubygem-narray/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= narray
-PORTVERSION= 0.6.0.8
+PORTVERSION= ${NARRAY_VERSION}
CATEGORIES= math rubygems
MASTER_SITES= RG
@@ -14,4 +14,6 @@ USE_RAKE= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+.include "${.CURDIR}/Makefile.version"
+
.include <bsd.port.mk>
diff --git a/math/rubygem-narray/Makefile.version b/math/rubygem-narray/Makefile.version
new file mode 100644
index 00000000000..fce305f84bf
--- /dev/null
+++ b/math/rubygem-narray/Makefile.version
@@ -0,0 +1 @@
+NARRAY_VERSION= 0.6.0.8