aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-09-22 23:15:21 +0800
committerbapt <bapt@FreeBSD.org>2016-09-22 23:15:21 +0800
commit56af77b02df96460067a4c7953f1b978a87dfbc0 (patch)
tree75c7294bdcc86fbdeab79e9d24f32b408d3174a3 /math
parent04e47ae2a8bc795d7b7986db54afd47eed6d7bf6 (diff)
downloadfreebsd-ports-graphics-56af77b02df96460067a4c7953f1b978a87dfbc0.tar.gz
freebsd-ports-graphics-56af77b02df96460067a4c7953f1b978a87dfbc0.tar.zst
freebsd-ports-graphics-56af77b02df96460067a4c7953f1b978a87dfbc0.zip
Even if upstream thinks clang does not support openmp we will soon know how to
make it works :)
Diffstat (limited to 'math')
-rw-r--r--math/openblas/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 14d539bbff8..d9719467acf 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -120,6 +120,7 @@ post-patch:
-e 's+%%XARGS%%+${XARGS}+' \
-e 's+%%REINPLACE_CMD%%+${REINPLACE_CMD}+' \
-e 's+$${CROSS_SUFFIX}+${LOCALBASE}/bin/+' \
+ -e '/Clang.*OpenMP/g' \
${WRKSRC}/Makefile.system
.if ${PORT_OPTIONS:MOPENMP}
${REINPLACE_CMD} -e "s+OPENBLAS_NUM_THREADS+OMP_NUM_THREADS+g" \