aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-12 13:56:44 +0800
committermaho <maho@FreeBSD.org>2007-01-12 13:56:44 +0800
commit58395d771dd810fc8d6fc185c7c2849fa09e47c2 (patch)
tree98e8e0d99f0d4f47ada024cad6f73c4d6b83a852 /math
parentcb311717a8685c3e2ecbc56300af3f2600e8275f (diff)
downloadfreebsd-ports-graphics-58395d771dd810fc8d6fc185c7c2849fa09e47c2.tar.gz
freebsd-ports-graphics-58395d771dd810fc8d6fc185c7c2849fa09e47c2.tar.zst
freebsd-ports-graphics-58395d771dd810fc8d6fc185c7c2849fa09e47c2.zip
* Use gfortran42 only and not gcc42.
* Bump portrevision.
Diffstat (limited to 'math')
-rw-r--r--math/arpack/Makefile10
-rw-r--r--math/metis/Makefile7
-rw-r--r--math/metis4/Makefile7
-rw-r--r--math/taucs/Makefile8
4 files changed, 23 insertions, 9 deletions
diff --git a/math/arpack/Makefile b/math/arpack/Makefile
index a90d2417c43..28cf5f245f4 100644
--- a/math/arpack/Makefile
+++ b/math/arpack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= arpack
PORTVERSION= 96
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://www.caam.rice.edu/software/ARPACK/SRC/
DISTFILES= ${PORTNAME}${PORTVERSION}.tar.gz patch.tar.gz
@@ -22,9 +22,6 @@ PATCH_SITES= http://www.caam.rice.edu/software/ARPACK/SRC/
MAINTAINER= ports@FreeBSD.org
COMMENT= Argand Library: large eigenvalue subroutines (serial version)
-WANT_FORTRAN= yes
-USE_GCC= 4.2+
-
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
@@ -47,6 +44,11 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
WRKSRC= ${WRKDIR}/ARPACK
WRKSRC_SHARED= ${WRKDIR}/ARPACK_SHARED
FFLAGS_SHARED= ${FFLAGS} ${PICFLAG}
diff --git a/math/metis/Makefile b/math/metis/Makefile
index c8ef53633f0..4047a98ae3e 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= metis
PORTVERSION= 4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/ \
http://www-users.cs.umn.edu/~karypis/metis/metis/files/
@@ -29,6 +29,11 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
post-patch:
${MKDIR} ${WRKSRC}_SHARED ; ${CP} -r ${WRKSRC}/* ${WRKSRC}_SHARED
diff --git a/math/metis4/Makefile b/math/metis4/Makefile
index c8ef53633f0..4047a98ae3e 100644
--- a/math/metis4/Makefile
+++ b/math/metis4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= metis
PORTVERSION= 4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/ \
http://www-users.cs.umn.edu/~karypis/metis/metis/files/
@@ -29,6 +29,11 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
post-patch:
${MKDIR} ${WRKSRC}_SHARED ; ${CP} -r ${WRKSRC}/* ${WRKSRC}_SHARED
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index 263f98c1be9..11e35727e94 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= taucs
PORTVERSION= 2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/
DISTNAME= ${PORTNAME}
@@ -31,8 +31,10 @@ LAPACK= -llapack
.endif
LIB_DEPENDS= metis.1:${PORTSDIR}/math/metis
-WANT_FORTRAN=yes
-USE_GCC=4.2+
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}