aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-06 06:03:09 +0800
committermiwi <miwi@FreeBSD.org>2009-06-06 06:03:09 +0800
commit61884d7e92ddf8d23957c42296378f8ba3183f51 (patch)
tree518e02a503a83fb34fc263db36af40f4d9022986 /math
parent520d683e041449309b217088e1819d49abfdaf5a (diff)
downloadfreebsd-ports-graphics-61884d7e92ddf8d23957c42296378f8ba3183f51.tar.gz
freebsd-ports-graphics-61884d7e92ddf8d23957c42296378f8ba3183f51.tar.zst
freebsd-ports-graphics-61884d7e92ddf8d23957c42296378f8ba3183f51.zip
BaseCnv provides a few simple functions for converting between
arbitrary number bases. It is as fast as I currently know how to make it (of course relying only on the lovely Perl). If you would rather utilize an object syntax for number-base conversion, please see Ken Williams's <Ken@Forum.Swarthmore.Edu> fine Math::BaseCalc module. WWW: http://search.cpan.org/dist/Math-BaseCnv/ PR: ports/135216 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-BaseCnv/Makefile27
-rw-r--r--math/p5-Math-BaseCnv/distinfo3
-rw-r--r--math/p5-Math-BaseCnv/pkg-descr8
-rw-r--r--math/p5-Math-BaseCnv/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b357499ddbc..84135758619 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -292,6 +292,7 @@
SUBDIR += p5-Math-Base36
SUBDIR += p5-Math-Base85
SUBDIR += p5-Math-BaseCalc
+ SUBDIR += p5-Math-BaseCnv
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-Bezier-Convert
SUBDIR += p5-Math-BigInt
diff --git a/math/p5-Math-BaseCnv/Makefile b/math/p5-Math-BaseCnv/Makefile
new file mode 100644
index 00000000000..8a08eeb1767
--- /dev/null
+++ b/math/p5-Math-BaseCnv/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Math-BaseCnv
+# Date created: 3rd June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BaseCnv
+PORTVERSION= 1.4.75
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}O6Pbr
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Fast functions to convert between number Bases
+
+BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+RUN_DEPENDS= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::BaseCnv.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BaseCnv/distinfo b/math/p5-Math-BaseCnv/distinfo
new file mode 100644
index 00000000000..94c9090c224
--- /dev/null
+++ b/math/p5-Math-BaseCnv/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-BaseCnv-1.4.75O6Pbr.tgz) = 60d5fb31db63e3d7a9807b0df37c4a80
+SHA256 (Math-BaseCnv-1.4.75O6Pbr.tgz) = 9ed74d703371ea192ab036ce11859f654b7d626dd1869317af470c325374ccfe
+SIZE (Math-BaseCnv-1.4.75O6Pbr.tgz) = 11698
diff --git a/math/p5-Math-BaseCnv/pkg-descr b/math/p5-Math-BaseCnv/pkg-descr
new file mode 100644
index 00000000000..e58aadc750a
--- /dev/null
+++ b/math/p5-Math-BaseCnv/pkg-descr
@@ -0,0 +1,8 @@
+BaseCnv provides a few simple functions for converting between
+arbitrary number bases. It is as fast as I currently know how
+to make it (of course relying only on the lovely Perl). If you
+would rather utilize an object syntax for number-base conversion,
+please see Ken Williams's <Ken@Forum.Swarthmore.Edu> fine
+Math::BaseCalc module.
+
+WWW: http://search.cpan.org/dist/Math-BaseCnv/
diff --git a/math/p5-Math-BaseCnv/pkg-plist b/math/p5-Math-BaseCnv/pkg-plist
new file mode 100644
index 00000000000..ce0398aaf1d
--- /dev/null
+++ b/math/p5-Math-BaseCnv/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/BaseCnv.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BaseCnv/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BaseCnv
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math