aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-01-28 17:07:47 +0800
committerkris <kris@FreeBSD.org>2007-01-28 17:07:47 +0800
commit62aa7fe94673789fb863494cfaf642ffdcff0b5d (patch)
treedadff634ddd561962b249aea07d4cfb45982ed98 /math
parent6f9d2cc492dfb48ff79f2a18bb35ea9fd095eac6 (diff)
downloadfreebsd-ports-graphics-62aa7fe94673789fb863494cfaf642ffdcff0b5d.tar.gz
freebsd-ports-graphics-62aa7fe94673789fb863494cfaf642ffdcff0b5d.tar.zst
freebsd-ports-graphics-62aa7fe94673789fb863494cfaf642ffdcff0b5d.zip
Use libtool port instead of included one to avoid objformat a.out botch
Diffstat (limited to 'math')
-rw-r--r--math/cln/Makefile1
-rw-r--r--math/cln/pkg-plist1
-rw-r--r--math/fftw/Makefile1
-rw-r--r--math/libmath++/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 96784d63fe0..552f8886bd9 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -18,6 +18,7 @@ COMMENT= Class Library for Numbers
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GCC= 3.4+
USE_GNOME= gnomehack gnometarget pkgconfig
diff --git a/math/cln/pkg-plist b/math/cln/pkg-plist
index d3dae7fbf36..e688eea0547 100644
--- a/math/cln/pkg-plist
+++ b/math/cln/pkg-plist
@@ -78,6 +78,7 @@ include/cln/univpoly_rational.h
include/cln/univpoly_real.h
include/cln/version.h
lib/libcln.a
+lib/libcln.la
lib/libcln.so
lib/libcln.so.4
libdata/pkgconfig/cln.pc
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 8de499bc6b2..018ad1e3c80 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -22,6 +22,7 @@ COMMENT?= Fast C routines to compute the Discrete Fourier Transform
FFTW_FLAVOR?= default
FFTW_SUFIX=
+USE_AUTOTOOLS= libtool:15
WANT_FORTRAN= yes #dummy but future use
BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
index a89a8c8bcfc..cc43e90615e 100644
--- a/math/libmath++/Makefile
+++ b/math/libmath++/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://www.robertjohnkaper.com/downloads/atlantik/
MAINTAINER= jhb@FreeBSD.org
COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes