aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2011-07-21 11:00:29 +0800
committermaho <maho@FreeBSD.org>2011-07-21 11:00:29 +0800
commit66e367dd72cfab7479bb8b8abea618b73a68a1bf (patch)
treefcfb93f7848b9711c9370aacad24870847571bcb /math
parentf676b7057a50757dffaa6c3559f3bfebaf364cc1 (diff)
downloadfreebsd-ports-graphics-66e367dd72cfab7479bb8b8abea618b73a68a1bf.tar.gz
freebsd-ports-graphics-66e367dd72cfab7479bb8b8abea618b73a68a1bf.tar.zst
freebsd-ports-graphics-66e367dd72cfab7479bb8b8abea618b73a68a1bf.zip
Better pkg-plist generation, making octave and octave-forge more
orthogonal. Discussion with: stephen@
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 9f884c09a5e..f498a030d27 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -117,7 +117,7 @@ post-install:
.endfor
.endif
${RM} -f ${WRKDIR}/PLIST
-.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave ${PREFIX}/lib/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave ${PREFIX}/lib/octave/site
+.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave/${OCTAVE_VERSION} ${PREFIX}/share/octave/site ${PREFIX}/lib/octave/${OCTAVE_VERSION}
@${FIND} -s $d -not -type d | \
${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s $d -type d -empty | \
@@ -126,6 +126,15 @@ post-install:
@${FIND} -s $d -type d -depth | \
${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
.endfor
+.for d in ${PREFIX}/libexec/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave/api-v45+ ${PREFIX}/libexec/octave/site ${PREFIX}/lib/octave/site
+ @${FIND} -s $d -type d -empty | \
+ ${SED} -e 's,^${PREFIX}/,@exec ${MKDIR} %D/,' \
+ -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
+ @${FIND} -s $d -type d -depth | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+.endfor
+ ${ECHO_CMD} @dirrm libexec/octave >> ${WRKDIR}/PLIST
+ ${ECHO_CMD} @dirrm share/octave >> ${WRKDIR}/PLIST
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
check: