aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2013-06-13 14:11:34 +0800
committerkevlo <kevlo@FreeBSD.org>2013-06-13 14:11:34 +0800
commit971489364b0194ddb3976ad53349359a38502b8a (patch)
tree483111c7eaaad535adb3c077bd853372b7d1f175 /math
parent4112aabcc91dc21e8f02488d522bb58828ddbf55 (diff)
downloadfreebsd-ports-graphics-971489364b0194ddb3976ad53349359a38502b8a.tar.gz
freebsd-ports-graphics-971489364b0194ddb3976ad53349359a38502b8a.tar.zst
freebsd-ports-graphics-971489364b0194ddb3976ad53349359a38502b8a.zip
Don't hard code the perl version. While here, fix MASTER_SITES.
PR: ports/179489 Submitted by: Javad Kouhi <javad dot kouhi at gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/algotutor/Makefile13
-rw-r--r--math/algotutor/files/patch-algotutor2
-rw-r--r--math/algotutor/pkg-descr2
3 files changed, 7 insertions, 10 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 1e12fabf574..7669439a86d 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -1,19 +1,14 @@
-# New ports collection makefile for: algotutor
-# Date created: 19 January 2005
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= algotutor
PORTVERSION= 0.8.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
-MASTER_SITES= http://saturn.stu.edu.tw/~ckhung/dl/
+MASTER_SITES= http://www.cyut.edu.tw/~ckhung/dl/
EXTRACT_SUFX= .tgz
MAINTAINER= kevlo@FreeBSD.org
-COMMENT= An interactive tutorial for algorithms and data structures
+COMMENT= Interactive tutorial for algorithms and data structures
BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -31,6 +26,8 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
post-patch:
${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
${PERL} -pi -e "s'!!PREFIX!!'${PREFIX}'g" ${WRKSRC}/algotutor
+ ${REINPLACE_CMD} -e 's,!!PERL_VERSION!!,${PERL_VERSION},' \
+ ${WRKSRC}/algotutor
do-install:
${MKDIR} ${SITE_PERL}/algotutor
diff --git a/math/algotutor/files/patch-algotutor b/math/algotutor/files/patch-algotutor
index 5b5fa38e962..0d3ba55e668 100644
--- a/math/algotutor/files/patch-algotutor
+++ b/math/algotutor/files/patch-algotutor
@@ -5,7 +5,7 @@
use strict;
use Getopt::Std;
-use lib '/usr/share/perl5/algotutor';
-+use lib '!!PREFIX!!/lib/perl5/site_perl/5.8.8/algotutor';
++use lib '!!PREFIX!!/lib/perl5/site_perl/!!PERL_VERSION!!/algotutor';
BEGIN {
my ($path) = $0 =~ m#(.*/)#;
diff --git a/math/algotutor/pkg-descr b/math/algotutor/pkg-descr
index 405304b3079..2c3dcc209d8 100644
--- a/math/algotutor/pkg-descr
+++ b/math/algotutor/pkg-descr
@@ -2,4 +2,4 @@ Algotutor is an interactive program for observing the intermediate
steps of algorithms. The target audience is computer science students
and/or anyone who studies algorithms and/or data structures.
-WWW: http://www.cyut.edu.tw/~ckhung/p/algotutor/
+WWW: http://www.cyut.edu.tw/~ckhung/p/algotutor/