aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-22 11:29:06 +0800
committermaho <maho@FreeBSD.org>2007-01-22 11:29:06 +0800
commitb077822fb362621befdf73ae7c6d1240b08698cd (patch)
treea0e8b5ee802e8d689a4656b3ed0beaaa3fd00bc0 /math
parent02a392afac0b6accdf4da5e85bb2408b2675db27 (diff)
downloadfreebsd-ports-graphics-b077822fb362621befdf73ae7c6d1240b08698cd.tar.gz
freebsd-ports-graphics-b077822fb362621befdf73ae7c6d1240b08698cd.tar.zst
freebsd-ports-graphics-b077822fb362621befdf73ae7c6d1240b08698cd.zip
* Migrate to gfortran.
* Bump port revision.
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/octave-forge/Makefile b/math/octave-forge/Makefile
index 9953e37b0db..f4b36effb2a 100644
--- a/math/octave-forge/Makefile
+++ b/math/octave-forge/Makefile
@@ -15,11 +15,11 @@ MASTER_SITE_SUBDIR= octave
MAINTAINER= maho@FreeBSD.org
COMMENT= Many additional features to math/octave
-BUILD_DEPENDS= qhull:${PORTSDIR}/math/qhull \
+BUILD_DEPENDS+= qhull:${PORTSDIR}/math/qhull \
octave:${PORTSDIR}/math/octave \
gcsplit:${PORTSDIR}/sysutils/coreutils \
bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS= octave:${PORTSDIR}/math/octave \
+RUN_DEPENDS+= octave:${PORTSDIR}/math/octave \
qhull:${PORTSDIR}/math/qhull \
bash:${PORTSDIR}/shells/bash
@@ -31,6 +31,12 @@ CONFIGURE_ARGS= --with-cc=${CC} \
--x-libraries=${X11BASE}/lib \
--x-includes=${X11BASE}/include
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 501000