aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2013-08-07 03:08:57 +0800
committerbf <bf@FreeBSD.org>2013-08-07 03:08:57 +0800
commitd154f5b200debdbb59c4c051c2b6bdca467de5aa (patch)
tree3bb161090bcd1bbe11bd8f153f5650ecba318b3c /math
parent96ca2d399d9804bc469b94c243c7f0be37af14cd (diff)
downloadfreebsd-ports-graphics-d154f5b200debdbb59c4c051c2b6bdca467de5aa.tar.gz
freebsd-ports-graphics-d154f5b200debdbb59c4c051c2b6bdca467de5aa.tar.zst
freebsd-ports-graphics-d154f5b200debdbb59c4c051c2b6bdca467de5aa.zip
Update math/glpk to 4.52.1 and adjust dependent ports
Diffstat (limited to 'math')
-rw-r--r--math/glpk/Makefile12
-rw-r--r--math/glpk/distinfo4
-rw-r--r--math/glpk/pkg-plist2
-rw-r--r--math/octave/Makefile2
4 files changed, 10 insertions, 10 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index d6ac19bf858..c74be63b4d0 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= glpk
-PORTVERSION= 4.50
+PORTVERSION= 4.52.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glpk
@@ -12,17 +12,17 @@ COMMENT= A GNU Linear Programming Kit
LICENSE= GPLv3
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
OPTIONS_DEFINE= IODBC MYSQL
IODBC_DESC= MathProg iodbc support
MYSQL_DESC= MathProg mysql support
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
CFLAGS+= -trigraphs
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -D_LSEEK_DECLARED -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-gmp
CONFLICTS= goblin-[0-9]*
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --disable-dl
.if ${PORT_OPTIONS:MIODBC}
CONFIGURE_ARGS+= --enable-odbc
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
.else
CONFIGURE_ARGS+= --disable-odbc
.endif
@@ -67,6 +67,6 @@ post-install:
.endif
check regression-test test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
.include <bsd.port.mk>
diff --git a/math/glpk/distinfo b/math/glpk/distinfo
index c04abf5e846..5f075791d43 100644
--- a/math/glpk/distinfo
+++ b/math/glpk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glpk-4.50.tar.gz) = 8173cee2b251796229103b805a6f3d194773435cfa2e3f3567fb0c6e7b6d9766
-SIZE (glpk-4.50.tar.gz) = 2806395
+SHA256 (glpk-4.52.1.tar.gz) = 3231685b9ff92d30ccbb5c21ba7815b25ba59c7d1e5194e57a880dd1ebb3e95b
+SIZE (glpk-4.52.1.tar.gz) = 2812957
diff --git a/math/glpk/pkg-plist b/math/glpk/pkg-plist
index 61775e654fd..5dff5febdda 100644
--- a/math/glpk/pkg-plist
+++ b/math/glpk/pkg-plist
@@ -4,4 +4,4 @@ include/glplpx.h
lib/libglpk.a
lib/libglpk.la
lib/libglpk.so
-lib/libglpk.so.35
+lib/libglpk.so.36
diff --git a/math/octave/Makefile b/math/octave/Makefile
index d7128865122..79a38e803b8 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.6.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/