aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-26 17:00:44 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-26 17:00:44 +0800
commitde6d7b44bb7db63037273f806184459c77308d20 (patch)
tree9ae64534d342eb91685c005b893a83b6942d26d0 /math
parent7e6080cb632da4793ddbd4f4c4feae20d8fe5d1c (diff)
downloadfreebsd-ports-graphics-de6d7b44bb7db63037273f806184459c77308d20.tar.gz
freebsd-ports-graphics-de6d7b44bb7db63037273f806184459c77308d20.tar.zst
freebsd-ports-graphics-de6d7b44bb7db63037273f806184459c77308d20.zip
- Add LICENSE (no commercial distribution allowed)
- Switch to USES=localbase - Switch to options helpers - Cosmetic fixes - Switch to new test framework
Diffstat (limited to 'math')
-rw-r--r--math/testu01/Makefile65
-rw-r--r--math/testu01/pkg-plist154
2 files changed, 111 insertions, 108 deletions
diff --git a/math/testu01/Makefile b/math/testu01/Makefile
index b791d04ef8a..7f4391866a6 100644
--- a/math/testu01/Makefile
+++ b/math/testu01/Makefile
@@ -13,59 +13,62 @@ EXTRACT_ONLY= ${PORTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities for statistical testing of uniform random number generators
+LICENSE= TestU01
+LICENSE_NAME= TestU01 license
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libgmp.so:math/gmp
-USES= gmake zip libtool
+CONFLICTS= emboss-[0-9]*
+
+USES= gmake zip libtool localbase
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}"
MAKE_ARGS= docdir="${DOCSDIR}" exdir="${EXAMPLESDIR}"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
CFLAGS+= -fPIC
-PLIST_SUB= PORTNAME="${PORTNAME}"
-CONFLICTS= emboss-[0-9]*
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|return|& (0)|' ${WRKSRC}/testu01/fftc.c
-.if empty(PORT_OPTIONS:MDOCS)
+
+post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/^SUBDIRS \=/s/ doc / /' ${WRKSRC}/Makefile.in
@${FIND} -X ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} \
-e '/^install-data-am\: /s/install-docDATA//'
-.endif
-.if empty(PORT_OPTIONS:MEXAMPLES)
+
+
+post-patch-EXAMPLES-off:
@${REINPLACE_CMD} -e '/^SUBDIRS \=/s/ examples / /' ${WRKSRC}/Makefile.in
-.endif
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/testu01.pdf ${STAGEDIR}${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${DISTDIR}/testu01.pdf ${STAGEDIR}${DOCSDIR}
-check regression-test test: build
+do-test:
@cd ${WRKSRC}/examples ; \
for f in [mx]*.c ; do \
- ${CC} ${CFLAGS} -c $${f} -I. -I../include ; \
+ ${CC} ${CFLAGS} -c $${f} -I. -I../include ; \
done ; \
for t in [befs]*.c; do \
- case $${t} in \
- ex3.c) x="my16807.o" ;; \
- ex7.c) x="mrg32k3a.o xorshift.o" ;; \
- scat.c) continue ;; \
- *) x="" ;; \
- esac ; \
- ${CC} ${CFLAGS} ${LDFLAGS} -o $${t%.c} $${t} -I. -I../include \
- -Wl,--as-needed $${x} ../testu01/.libs/libtestu01.so \
- ../probdist/.libs/libprobdist.so ../mylib/.libs/libmylib.so -lm ; \
- ${ECHO_CMD} "Running $${t%.c}..." ; \
- ${SETENV} \
- LD_LIBRARY_PATH=../testu01/.libs:../probdist/.libs:../mylib/.libs \
- ./$${t%.c} ; \
+ case $${t} in \
+ ex3.c) x="my16807.o" ;; \
+ ex7.c) x="mrg32k3a.o xorshift.o" ;; \
+ scat.c) continue ;; \
+ *) x="" ;; \
+ esac ; \
+ ${CC} ${CFLAGS} ${LDFLAGS} -o $${t%.c} $${t} -I. -I../include \
+ -Wl,--as-needed $${x} ../testu01/.libs/libtestu01.so \
+ ../probdist/.libs/libprobdist.so ../mylib/.libs/libmylib.so -lm ; \
+ ${ECHO_CMD} "Running $${t%.c}..." ; \
+ ${SETENV} \
+ LD_LIBRARY_PATH=../testu01/.libs:../probdist/.libs:../mylib/.libs \
+ ./$${t%.c} ; \
done
.include <bsd.port.mk>
diff --git a/math/testu01/pkg-plist b/math/testu01/pkg-plist
index 54fcd4a3ba2..99d55a5c2ce 100644
--- a/math/testu01/pkg-plist
+++ b/math/testu01/pkg-plist
@@ -1,81 +1,81 @@
bin/tcode
-include/%%PORTNAME%%/TestU01.h
-include/%%PORTNAME%%/addstr.h
-include/%%PORTNAME%%/bbattery.h
-include/%%PORTNAME%%/bitset.h
-include/%%PORTNAME%%/chrono.h
-include/%%PORTNAME%%/fbar.h
-include/%%PORTNAME%%/fcho.h
-include/%%PORTNAME%%/fcong.h
-include/%%PORTNAME%%/fdist.h
-include/%%PORTNAME%%/ffam.h
-include/%%PORTNAME%%/ffsr.h
-include/%%PORTNAME%%/finv.h
-include/%%PORTNAME%%/fknuth.h
-include/%%PORTNAME%%/fmarsa.h
-include/%%PORTNAME%%/fmass.h
-include/%%PORTNAME%%/fmultin.h
-include/%%PORTNAME%%/fnpair.h
-include/%%PORTNAME%%/fres.h
-include/%%PORTNAME%%/fspectral.h
-include/%%PORTNAME%%/fstring.h
-include/%%PORTNAME%%/ftab.h
-include/%%PORTNAME%%/fvaria.h
-include/%%PORTNAME%%/fwalk.h
-include/%%PORTNAME%%/gdef.h
-include/%%PORTNAME%%/gdefconf.h
-include/%%PORTNAME%%/gofs.h
-include/%%PORTNAME%%/gofw.h
-include/%%PORTNAME%%/mystr.h
-include/%%PORTNAME%%/num.h
-include/%%PORTNAME%%/num2.h
-include/%%PORTNAME%%/rijndael-alg-fst.h
-include/%%PORTNAME%%/scatter.h
-include/%%PORTNAME%%/scomp.h
-include/%%PORTNAME%%/sentrop.h
-include/%%PORTNAME%%/sknuth.h
-include/%%PORTNAME%%/smarsa.h
-include/%%PORTNAME%%/smultin.h
-include/%%PORTNAME%%/snpair.h
-include/%%PORTNAME%%/sres.h
-include/%%PORTNAME%%/sspacings.h
-include/%%PORTNAME%%/sspectral.h
-include/%%PORTNAME%%/sstring.h
-include/%%PORTNAME%%/statcoll.h
-include/%%PORTNAME%%/svaria.h
-include/%%PORTNAME%%/swalk.h
-include/%%PORTNAME%%/swrite.h
-include/%%PORTNAME%%/tables.h
-include/%%PORTNAME%%/tu01_sha1.h
-include/%%PORTNAME%%/uautomata.h
-include/%%PORTNAME%%/ubrent.h
-include/%%PORTNAME%%/ucarry.h
-include/%%PORTNAME%%/ucrypto.h
-include/%%PORTNAME%%/ucubic.h
-include/%%PORTNAME%%/udeng.h
-include/%%PORTNAME%%/ufile.h
-include/%%PORTNAME%%/ugfsr.h
-include/%%PORTNAME%%/ugranger.h
-include/%%PORTNAME%%/uinv.h
-include/%%PORTNAME%%/uknuth.h
-include/%%PORTNAME%%/ulcg.h
-include/%%PORTNAME%%/ulec.h
-include/%%PORTNAME%%/umarsa.h
-include/%%PORTNAME%%/umrg.h
-include/%%PORTNAME%%/unif01.h
-include/%%PORTNAME%%/unumrec.h
-include/%%PORTNAME%%/uquad.h
-include/%%PORTNAME%%/usoft.h
-include/%%PORTNAME%%/utaus.h
-include/%%PORTNAME%%/utezuka.h
-include/%%PORTNAME%%/util.h
-include/%%PORTNAME%%/utouzin.h
-include/%%PORTNAME%%/uvaria.h
-include/%%PORTNAME%%/uweyl.h
-include/%%PORTNAME%%/uwu.h
-include/%%PORTNAME%%/uxorshift.h
-include/%%PORTNAME%%/vectorsF2.h
-include/%%PORTNAME%%/wdist.h
+include/TestU01/TestU01.h
+include/TestU01/addstr.h
+include/TestU01/bbattery.h
+include/TestU01/bitset.h
+include/TestU01/chrono.h
+include/TestU01/fbar.h
+include/TestU01/fcho.h
+include/TestU01/fcong.h
+include/TestU01/fdist.h
+include/TestU01/ffam.h
+include/TestU01/ffsr.h
+include/TestU01/finv.h
+include/TestU01/fknuth.h
+include/TestU01/fmarsa.h
+include/TestU01/fmass.h
+include/TestU01/fmultin.h
+include/TestU01/fnpair.h
+include/TestU01/fres.h
+include/TestU01/fspectral.h
+include/TestU01/fstring.h
+include/TestU01/ftab.h
+include/TestU01/fvaria.h
+include/TestU01/fwalk.h
+include/TestU01/gdef.h
+include/TestU01/gdefconf.h
+include/TestU01/gofs.h
+include/TestU01/gofw.h
+include/TestU01/mystr.h
+include/TestU01/num.h
+include/TestU01/num2.h
+include/TestU01/rijndael-alg-fst.h
+include/TestU01/scatter.h
+include/TestU01/scomp.h
+include/TestU01/sentrop.h
+include/TestU01/sknuth.h
+include/TestU01/smarsa.h
+include/TestU01/smultin.h
+include/TestU01/snpair.h
+include/TestU01/sres.h
+include/TestU01/sspacings.h
+include/TestU01/sspectral.h
+include/TestU01/sstring.h
+include/TestU01/statcoll.h
+include/TestU01/svaria.h
+include/TestU01/swalk.h
+include/TestU01/swrite.h
+include/TestU01/tables.h
+include/TestU01/tu01_sha1.h
+include/TestU01/uautomata.h
+include/TestU01/ubrent.h
+include/TestU01/ucarry.h
+include/TestU01/ucrypto.h
+include/TestU01/ucubic.h
+include/TestU01/udeng.h
+include/TestU01/ufile.h
+include/TestU01/ugfsr.h
+include/TestU01/ugranger.h
+include/TestU01/uinv.h
+include/TestU01/uknuth.h
+include/TestU01/ulcg.h
+include/TestU01/ulec.h
+include/TestU01/umarsa.h
+include/TestU01/umrg.h
+include/TestU01/unif01.h
+include/TestU01/unumrec.h
+include/TestU01/uquad.h
+include/TestU01/usoft.h
+include/TestU01/utaus.h
+include/TestU01/utezuka.h
+include/TestU01/util.h
+include/TestU01/utouzin.h
+include/TestU01/uvaria.h
+include/TestU01/uweyl.h
+include/TestU01/uwu.h
+include/TestU01/uxorshift.h
+include/TestU01/vectorsF2.h
+include/TestU01/wdist.h
lib/libmylib.a
lib/libmylib.so
lib/libmylib.so.0