aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-07 23:04:14 +0800
committerbapt <bapt@FreeBSD.org>2014-04-07 23:04:14 +0800
commite77eecc02b57f4343e2224ccd8f68e6aca4ddae9 (patch)
treeff100abe9310b2e9b2e7badf6181bca5090f5ae6 /math
parenta3eb1fcb82d25593630e19588778b1897d200558 (diff)
downloadfreebsd-ports-graphics-e77eecc02b57f4343e2224ccd8f68e6aca4ddae9.tar.gz
freebsd-ports-graphics-e77eecc02b57f4343e2224ccd8f68e6aca4ddae9.tar.zst
freebsd-ports-graphics-e77eecc02b57f4343e2224ccd8f68e6aca4ddae9.zip
Support stage
Diffstat (limited to 'math')
-rw-r--r--math/ruby-numru_units/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/ruby-numru_units/Makefile b/math/ruby-numru_units/Makefile
index 7905fd68dda..ae3031a9cce 100644
--- a/math/ruby-numru_units/Makefile
+++ b/math/ruby-numru_units/Makefile
@@ -14,7 +14,9 @@ DIST_SUBDIR= ruby
MAINTAINER= murashin@gfd-dennou.org
COMMENT= A class to handle units of physical quantities for Ruby
-LICENSE= BSD
+OPTIONS_DEFINE= DOCS
+
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USE_RUBY= yes
@@ -22,16 +24,11 @@ NO_BUILD= yes
DOCS= ChangeLog LICENSE.txt doc/units.html doc/units.rd
-NO_STAGE= yes
do-install:
- @cd ${WRKSRC}/ && ${RUBY} ./install.rb
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
+ @cd ${WRKSRC}/ && ${RUBY} ./install.rb -d ${STAGEDIR}${RUBY_SITELIBDIR}
+ @${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}
.endfor
-.endif
.include <bsd.port.mk>