aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-06-09 23:29:38 +0800
committeradamw <adamw@FreeBSD.org>2016-06-09 23:29:38 +0800
commitede4d64330f04f1e6a47be42c4869f1d60336829 (patch)
tree2348e38077663ec0c0f025ac81f5a4e11b07142c /math
parent9b26ba8306f4fcee841897595dc839ebeae5b0f2 (diff)
downloadfreebsd-ports-graphics-ede4d64330f04f1e6a47be42c4869f1d60336829.tar.gz
freebsd-ports-graphics-ede4d64330f04f1e6a47be42c4869f1d60336829.tar.zst
freebsd-ports-graphics-ede4d64330f04f1e6a47be42c4869f1d60336829.zip
libraries are declared with LIB_DEPENDS, not RUN_DEPENDS.
Committed under "just fix it."
Diffstat (limited to 'math')
-rw-r--r--math/libflame/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/libflame/Makefile b/math/libflame/Makefile
index 6645ef70dee..5a10ab853c0 100644
--- a/math/libflame/Makefile
+++ b/math/libflame/Makefile
@@ -124,19 +124,19 @@ WITH_BLAS?= reference
.if ! ${PORT_OPTIONS:MBUILTIN_BLAS}
.if ${WITH_BLAS} == atlas
-RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
BLAS= -lptf77blas
.elif ${WITH_BLAS} == atlas_c
-RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
BLAS= -lptcblas
.elif ${WITH_BLAS} == gotoblas
-RUN_DEPENDS += ${LOCALBASE}/lib/libgoto2p.so:math/gotoblas
+LIB_DEPENDS+= libgoto2p:math/gotoblas
BLAS= -lgoto2p
.elif ${WITH_BLAS} == reference
-RUN_DEPENDS += ${LOCALBASE}/lib/libblas.so:math/blas
+LIB_DEPENDS+= libblas.so:math/blas
BLAS= -lblas
.elif ${WITH_BLAS} == reference_c
-RUN_DEPENDS += ${LOCALBASE}/lib/libgslcblas.so:math/gsl
+LIB_DEPENDS+= libgslcblas.so:math/gsl
BLAS= -lgslcblas
.endif #WITH_BLAS
.endif #WITH_BUILTIN_BLAS
@@ -144,19 +144,19 @@ BLAS= -lgslcblas
.if ${PORT_OPTIONS:MEXTERNAL_LAPACK}
.if !empty(WITH_BLAS:Matlas*)
.if ${PORT_OPTIONS:MBUILTIN_BLAS}
-RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
.endif
LAPACK= -lalapack -lptcblas -lptf77blas
.elif ${WITH_BLAS} == gotoblas
.if ${PORT_OPTIONS:MBUILTIN_BLAS}
-RUN_DEPENDS += ${LOCALBASE}/lib/libgoto2p.so:math/gotoblas
+LIB_DEPENDS+= libgoto2p:math/gotoblas
.endif
LAPACK= -lgoto2p
.elif !empty(WITH_BLAS:Mreference*)
-RUN_DEPENDS += ${LOCALBASE}/lib/liblapack.so:math/lapack
+LIB_DEPENDS+= liblapack.so:math/lapack
LAPACK= -llapack
.if ${PORT_OPTIONS:MBUILTIN_BLAS} || ${PORT_OPTIONS:MCBLAS}
-RUN_DEPENDS += ${LOCALBASE}/lib/libblas.so:math/blas
+LIB_DEPENDS+= libblas.so:math/blas
LAPACK+= -lblas
.endif
.endif #WITH_BLAS