aboutsummaryrefslogtreecommitdiffstats
path: root/mbone/imm/Makefile
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>1996-11-20 05:42:30 +0800
committerfenner <fenner@FreeBSD.org>1996-11-20 05:42:30 +0800
commitce71b32c2991350f4946a4e8f3fc29189235ec3b (patch)
treeb9d7c4876bdee3e81c7a96c837ce5139e02720b4 /mbone/imm/Makefile
parent8eddc1add0aacc7e2597007da5094eb453414867 (diff)
downloadfreebsd-ports-graphics-ce71b32c2991350f4946a4e8f3fc29189235ec3b.tar.gz
freebsd-ports-graphics-ce71b32c2991350f4946a4e8f3fc29189235ec3b.tar.zst
freebsd-ports-graphics-ce71b32c2991350f4946a4e8f3fc29189235ec3b.zip
Upgraded to imm 3.5a1 . This port is no longer BROKEN.
Diffstat (limited to 'mbone/imm/Makefile')
-rw-r--r--mbone/imm/Makefile33
1 files changed, 25 insertions, 8 deletions
diff --git a/mbone/imm/Makefile b/mbone/imm/Makefile
index 88488dc1487..39c2ffee6dc 100644
--- a/mbone/imm/Makefile
+++ b/mbone/imm/Makefile
@@ -1,19 +1,36 @@
# New ports collection makefile for: imm
-# Version required: 3.3
+# Version required: 3.5a1
# Date created: 13 October 1994
# Whom: wollman
#
-# $Id: Makefile,v 1.8 1996/11/11 07:05:28 asami Exp $
+# $Id: Makefile,v 1.9 1996/11/18 11:32:56 asami Exp $
#
-DISTNAME= imm-3.3
+DISTNAME= imm-3.5a1
CATEGORIES= mbone
-MASTER_SITES= ftp://ftp.ucs.ed.ac.uk/pub/videoconference/imm/
-DISTFILES= imm.src.tar.Z
+MASTER_SITES= ftp://ftp.hawaii.edu/paccom/imm-3.5a1/
+DISTFILES= imm.source.tar.Z
+WRKSRC= ${WRKDIR}/mnm
-LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
+MAINTAINER= fenner@freebsd.org
-BROKEN= yes # depends on tk-3.6
-WRKSRC= ${WRKDIR}/src
+LIB_DEPENDS= tk41\\.1:${PORTSDIR}/x11/tk41
+
+USE_X11= yes
+
+# The included makefile doesn't have an "install" target.
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/imm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/immserv ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/lscomp ${PREFIX}/bin
+# and no man pages at all yet.
+# But include the very limited documentation
+ ${MKDIR} ${PREFIX}/share/doc/imm
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/imm
+ ${INSTALL_DATA} ${WRKSRC}/imm_readme.txt ${PREFIX}/share/doc/imm
+.endif
+# The sdr plugin is pretty much required.
+ ${INSTALL_DATA} ${WRKSRC}/sdr2.plugin.S53.image.imm ${PREFIX}/share/doc/imm
.include <bsd.port.mk>