aboutsummaryrefslogtreecommitdiffstats
path: root/misc/31upgrade
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-03-29 15:09:48 +0800
committerasami <asami@FreeBSD.org>1999-03-29 15:09:48 +0800
commit7931da6a896ef8f64aacecf5c67d6c1ffa5af05e (patch)
tree3389aeddef64feaa6154efa3ce34d1be40c7d404 /misc/31upgrade
parentd72b5028c66e505114e3c9fddd68e2e1193ace57 (diff)
downloadfreebsd-ports-graphics-7931da6a896ef8f64aacecf5c67d6c1ffa5af05e.tar.gz
freebsd-ports-graphics-7931da6a896ef8f64aacecf5c67d6c1ffa5af05e.tar.zst
freebsd-ports-graphics-7931da6a896ef8f64aacecf5c67d6c1ffa5af05e.zip
Install /var/db/pkg/.mkversion to check version against bsd.port.mk.
Change IGNORE to FORBIDDEN.
Diffstat (limited to 'misc/31upgrade')
-rw-r--r--misc/31upgrade/Makefile10
-rw-r--r--misc/31upgrade/pkg-install5
-rw-r--r--misc/31upgrade/pkg-plist1
3 files changed, 13 insertions, 3 deletions
diff --git a/misc/31upgrade/Makefile b/misc/31upgrade/Makefile
index 530c7fff9e6..46052f5746a 100644
--- a/misc/31upgrade/Makefile
+++ b/misc/31upgrade/Makefile
@@ -3,7 +3,7 @@
# Date created: 8 Mar 1999
# Whom: asami
#
-# $Id: Makefile,v 1.2 1999/03/09 20:57:23 asami Exp $
+# $Id: Makefile,v 1.3 1999/03/10 22:10:51 asami Exp $
#
DISTNAME= 31upgrade-1999.03.08
@@ -17,11 +17,15 @@ MAINTAINER= asami@Freebsd.ORG
.if !defined(PACKAGE_BUILDING)
BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
.elif ${OSVERSION} < 310000
-IGNORE= this needs to be built on a 3.1-stable system
+FORBIDDEN= this needs to be built on a 3.1-stable system
.endif
NO_MTREE= yes
PREFIX= /
NO_BUILD= yes
-NO_INSTALL= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
+
+do-install:
+ ${SED} -e "s/%%VERSION%%/${BSDPORTMKVERSION}/" ${PKGDIR}/INSTALL \
+ > ${PKGINSTALL}
.include <bsd.port.post.mk>
diff --git a/misc/31upgrade/pkg-install b/misc/31upgrade/pkg-install
new file mode 100644
index 00000000000..83a9f3edb0d
--- /dev/null
+++ b/misc/31upgrade/pkg-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+echo %%VERSION%% > /var/db/pkg/.mkversion
diff --git a/misc/31upgrade/pkg-plist b/misc/31upgrade/pkg-plist
index b641c83f450..f2a23776234 100644
--- a/misc/31upgrade/pkg-plist
+++ b/misc/31upgrade/pkg-plist
@@ -1 +1,2 @@
usr/bin/fetch
+usr/libexec/ld-elf.so.1