aboutsummaryrefslogtreecommitdiffstats
path: root/misc/bbjd
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-03-07 00:41:53 +0800
committerbillf <billf@FreeBSD.org>1999-03-07 00:41:53 +0800
commit8c7e876340af9871086fde9c5e12a37113c3148e (patch)
tree802794ef7b00719369bf111ee0b4ae423a8cffd0 /misc/bbjd
parentf343741e3100a9d83fd915cd5b618408d299aadc (diff)
downloadfreebsd-ports-graphics-8c7e876340af9871086fde9c5e12a37113c3148e.tar.gz
freebsd-ports-graphics-8c7e876340af9871086fde9c5e12a37113c3148e.tar.zst
freebsd-ports-graphics-8c7e876340af9871086fde9c5e12a37113c3148e.zip
Bbjd is a tool to calculate the optimum strategy playing Black Jack. This
program may be used to prove that when playing Black Jack it is possible to beat the casino. Probably, Black Jack is the only game offered by casinos, where it is possible to win in the long term (and this fact is mathematically proven). PR: ports/9895 Submitted By: Dima Sivachenko <dima@Chg.RU> [committers note: this can be addicting.]
Diffstat (limited to 'misc/bbjd')
-rw-r--r--misc/bbjd/Makefile30
-rw-r--r--misc/bbjd/distinfo1
-rw-r--r--misc/bbjd/files/patch-aa22
-rw-r--r--misc/bbjd/pkg-comment1
-rw-r--r--misc/bbjd/pkg-descr8
-rw-r--r--misc/bbjd/pkg-message4
-rw-r--r--misc/bbjd/pkg-plist6
7 files changed, 72 insertions, 0 deletions
diff --git a/misc/bbjd/Makefile b/misc/bbjd/Makefile
new file mode 100644
index 00000000000..79aecf7a199
--- /dev/null
+++ b/misc/bbjd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: bbjd
+# Version required: 1.01
+# Date created: 3 February 1999
+# Whom: Dima Sivachenko
+#
+# $Id: $
+#
+
+DISTNAME= bbjd-1.01
+CATEGORIES= misc math
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/strategy
+
+MAINTAINER= dima@chg.ru
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/bbjd
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bbjd ${PREFIX}/bin/
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/simbj ${PREFIX}/bin/
+ @ ${MKDIR} ${PREFIX}/share/bbjd
+ @ ${INSTALL_DATA} ${WRKSRC}/Interactive ${PREFIX}/share/bbjd/
+ @ ${INSTALL_DATA} ${WRKSRC}/Simulation ${PREFIX}/share/bbjd/
+ @ ${INSTALL_DATA} ${WRKSRC}/Theory ${PREFIX}/share/bbjd/
+
+post-install:
+ @ ${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/misc/bbjd/distinfo b/misc/bbjd/distinfo
new file mode 100644
index 00000000000..876ee866102
--- /dev/null
+++ b/misc/bbjd/distinfo
@@ -0,0 +1 @@
+MD5 (bbjd-1.01.tar.gz) = 674b296e9f4cf87f4fee1515b76083e7
diff --git a/misc/bbjd/files/patch-aa b/misc/bbjd/files/patch-aa
new file mode 100644
index 00000000000..fe17da45b71
--- /dev/null
+++ b/misc/bbjd/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.orig Mon Oct 26 05:47:44 1998
++++ Makefile Sun Feb 14 17:39:37 1999
+@@ -13,8 +13,8 @@
+ -Wmissing-declarations -Wreturn-type \
+ -Wnested-externs -Wwrite-strings -Wcast-qual
+ INCDIR = -I. -I/usr/include
+-CFLAGS = $(DEFINES) $(LANG_OPTIONS) $(WARN_OPTIONS) $(INCDIR)
+-COPTS = -O2
++CFLAGS?= -O2
++CFLAGS+= $(DEFINES) $(LANG_OPTIONS) $(WARN_OPTIONS) $(INCDIR)
+
+ ######## link options ########
+ LD = gcc
+@@ -36,7 +36,7 @@
+
+ %o: %c
+ @echo --- compiling: $< ---
+- $(CC) $(CFLAGS) $(COPTS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm -f probability.o interactive.o display.o simulate.o core
diff --git a/misc/bbjd/pkg-comment b/misc/bbjd/pkg-comment
new file mode 100644
index 00000000000..ee7277b9c86
--- /dev/null
+++ b/misc/bbjd/pkg-comment
@@ -0,0 +1 @@
+bbjd - beat the blackjack dealer
diff --git a/misc/bbjd/pkg-descr b/misc/bbjd/pkg-descr
new file mode 100644
index 00000000000..e77d09bdfd4
--- /dev/null
+++ b/misc/bbjd/pkg-descr
@@ -0,0 +1,8 @@
+Bbjd is a tool to calculate the optimum strategy playing Black Jack. This
+program may be used to prove that when playing Black Jack it is possible to
+beat the casino. Probably, Black Jack is the only game offered by casinos,
+where it is possible to win in the long term (and this fact is mathematically
+proven).
+
+--Dima
+dima@chg.ru
diff --git a/misc/bbjd/pkg-message b/misc/bbjd/pkg-message
new file mode 100644
index 00000000000..1d3027b8c69
--- /dev/null
+++ b/misc/bbjd/pkg-message
@@ -0,0 +1,4 @@
+-------------------------------------------------------------------------------
+This program has no man-pages. Please read documentation installed in
+share/bbjd directory.
+-------------------------------------------------------------------------------
diff --git a/misc/bbjd/pkg-plist b/misc/bbjd/pkg-plist
new file mode 100644
index 00000000000..be862251905
--- /dev/null
+++ b/misc/bbjd/pkg-plist
@@ -0,0 +1,6 @@
+bin/bbjd
+bin/simbj
+share/bbjd/Interactive
+share/bbjd/Simulation
+share/bbjd/Theory
+@dirrm share/bbjd