aboutsummaryrefslogtreecommitdiffstats
path: root/misc/cave/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-31 03:24:46 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-31 03:24:46 +0800
commite8c3b0e7c483d36e4020ce454e0c719fec450016 (patch)
tree79648c493583d57471e1e1c3f593b0c7105ca780 /misc/cave/Makefile
parentfbc005cf84975cf1d0caa56a418b7e2f58ac60c2 (diff)
downloadfreebsd-ports-graphics-e8c3b0e7c483d36e4020ce454e0c719fec450016.tar.gz
freebsd-ports-graphics-e8c3b0e7c483d36e4020ce454e0c719fec450016.tar.zst
freebsd-ports-graphics-e8c3b0e7c483d36e4020ce454e0c719fec450016.zip
add cave 0.3
Character Animation Viewer for Everyone
Diffstat (limited to 'misc/cave/Makefile')
-rw-r--r--misc/cave/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/cave/Makefile b/misc/cave/Makefile
new file mode 100644
index 00000000000..6ca3a6ed90c
--- /dev/null
+++ b/misc/cave/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: cave
+# Date created: Dec 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cave
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://m-net.arbornet.org/~bjk/cave/download/
+
+MAINTAINER= ports@FreeBSD.org
+
+MAN1= cave.1
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+pre-install:
+ @${GZIP_CMD} -d ${WRKSRC}/${MAN1}.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>