aboutsummaryrefslogtreecommitdiffstats
path: root/misc/deco
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-08-16 21:51:31 +0800
committerdemon <demon@FreeBSD.org>2001-08-16 21:51:31 +0800
commit4b493de5db340e795f7a1654b527a324a0a06fe6 (patch)
tree72fa40ebb916778c3ec261fd9c78d617c76d0787 /misc/deco
parentcd3dceb416f7122b3e5053fdca4ddb25ffa7ea53 (diff)
downloadfreebsd-ports-graphics-4b493de5db340e795f7a1654b527a324a0a06fe6.tar.gz
freebsd-ports-graphics-4b493de5db340e795f7a1654b527a324a0a06fe6.tar.zst
freebsd-ports-graphics-4b493de5db340e795f7a1654b527a324a0a06fe6.zip
Do not coredump when viewing files larger that 8Mb.
Bump PORTREVISION Minor cosmetic fixes in the Makefile. Submitted by: Pavel Biryukov <pavel@svegapro.ru>
Diffstat (limited to 'misc/deco')
-rw-r--r--misc/deco/Makefile23
-rw-r--r--misc/deco/files/patch-af11
2 files changed, 23 insertions, 11 deletions
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index 6ef7a20193e..129ffba7891 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -5,19 +5,20 @@
# $FreeBSD$
#
-PORTNAME= deco
-PORTVERSION= 3.8.3
-CATEGORIES= misc
-MASTER_SITES= ftp://ftp.cronyx.ru/cronyx/deco/
-DISTNAME= deco383
-EXTRACT_SUFX= .tgz
+PORTNAME= deco
+PORTVERSION= 3.8.3
+PORTREVISION= 1
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.cronyx.ru/cronyx/deco/
+DISTNAME= deco383
+EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
-WRKSRC= ${WRKDIR}/deco383
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --libdir=${PREFIX}/share
-CONFIGURE_ENV= ac_cv_lib_ncurses_tgetent=no
-MAN1= deco.1 deco-r.1
+WRKSRC= ${WRKDIR}/deco383
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libdir=${PREFIX}/share
+CONFIGURE_ENV= ac_cv_lib_ncurses_tgetent=no
+MAN1= deco.1 deco-r.1
.include <bsd.port.mk>
diff --git a/misc/deco/files/patch-af b/misc/deco/files/patch-af
new file mode 100644
index 00000000000..dc1b20e0308
--- /dev/null
+++ b/misc/deco/files/patch-af
@@ -0,0 +1,11 @@
+--- rec.c.orig Thu Aug 16 17:29:07 2001
++++ rec.c Thu Aug 16 17:29:35 2001
+@@ -61,7 +61,7 @@
+ static char *scanbuf, *pbuf;
+ static char *tfilename;
+ static int eoln;
+-static int MAXLEN = ((unsigned int) (int) -1 >> 1) / sizeof (struct index);
++static int MAXLEN = 32767;
+
+ static int ffcopy (int from, int to)
+ {