aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gkrellm-reminder
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2001-12-15 16:00:40 +0800
committerpat <pat@FreeBSD.org>2001-12-15 16:00:40 +0800
commit51b75620fa8b8e9ef4e8abdbe0d1493e65202956 (patch)
treebe30bdae74f33bd79623406bb758d1bab52bf0cd /misc/gkrellm-reminder
parent0979c03244d73cdb77413b49b8001b348a068824 (diff)
downloadfreebsd-ports-graphics-51b75620fa8b8e9ef4e8abdbe0d1493e65202956.tar.gz
freebsd-ports-graphics-51b75620fa8b8e9ef4e8abdbe0d1493e65202956.tar.zst
freebsd-ports-graphics-51b75620fa8b8e9ef4e8abdbe0d1493e65202956.zip
Add misc/gkrellm-reminder, a plugin that reminds you of events
Diffstat (limited to 'misc/gkrellm-reminder')
-rw-r--r--misc/gkrellm-reminder/Makefile27
-rw-r--r--misc/gkrellm-reminder/distinfo1
-rw-r--r--misc/gkrellm-reminder/files/patch-Makefile25
-rw-r--r--misc/gkrellm-reminder/pkg-comment1
-rw-r--r--misc/gkrellm-reminder/pkg-descr7
-rw-r--r--misc/gkrellm-reminder/pkg-plist1
6 files changed, 62 insertions, 0 deletions
diff --git a/misc/gkrellm-reminder/Makefile b/misc/gkrellm-reminder/Makefile
new file mode 100644
index 00000000000..f2ded7ae66a
--- /dev/null
+++ b/misc/gkrellm-reminder/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gkrellm-reminder
+# Date Created: Sat Dec 15 01:56:45 EST 2001
+# Whom: pat
+#
+# $FreeBSD$
+#
+
+PORTNAME= reminder
+PORTVERSION= 0.3.4
+CATEGORIES= misc
+MASTER_SITES= http://www.engr.orst.edu/~simonsen/reminder/
+PKGNAMEPREFIX= gkrellm-
+
+MAINTAINER= pat@FreeBSD.org
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_IMLIB= yes
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/reminder.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+
+.include <bsd.port.mk>
diff --git a/misc/gkrellm-reminder/distinfo b/misc/gkrellm-reminder/distinfo
new file mode 100644
index 00000000000..73d9dd1d25e
--- /dev/null
+++ b/misc/gkrellm-reminder/distinfo
@@ -0,0 +1 @@
+MD5 (reminder-0.3.4.tar.gz) = e2534864b15b68d70e8e5264d52c4643
diff --git a/misc/gkrellm-reminder/files/patch-Makefile b/misc/gkrellm-reminder/files/patch-Makefile
new file mode 100644
index 00000000000..b53eb5a8ba7
--- /dev/null
+++ b/misc/gkrellm-reminder/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Sat Dec 15 01:59:31 2001
++++ Makefile Sat Dec 15 02:01:26 2001
+@@ -1,16 +1,14 @@
+-GTK_INCLUDE = `gtk-config --cflags`
+-GTK_LIB = `gtk-config --libs`
++GTK_INCLUDE = `${GTK_CONFIG} --cflags`
++GTK_LIB = `${GTK_CONFIG} --libs`
+
+-IMLIB_INCLUDE = `imlib-config --cflags-gdk`
+-IMLIB_LIB = `imlib-config --libs-gdk`
++IMLIB_INCLUDE = `${IMLIB_CONFIG} --cflags-gdk`
++IMLIB_LIB = `${IMLIB_CONFIG} --libs-gdk`
+
+-CFLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) -I/usr/pkg/include
++CFLAGS += -Wall $(GTK_INCLUDE) $(IMLIB_INCLUDE)
+
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+
+-LFLAGS = -shared -L/usr/pkg/lib
+-
+-CC = gcc
++LFLAGS = -shared
+
+ all: reminder.so
+
diff --git a/misc/gkrellm-reminder/pkg-comment b/misc/gkrellm-reminder/pkg-comment
new file mode 100644
index 00000000000..2d4ca33b27b
--- /dev/null
+++ b/misc/gkrellm-reminder/pkg-comment
@@ -0,0 +1 @@
+GKrellM plugin that reminds you of important events
diff --git a/misc/gkrellm-reminder/pkg-descr b/misc/gkrellm-reminder/pkg-descr
new file mode 100644
index 00000000000..8f2d48ed4b5
--- /dev/null
+++ b/misc/gkrellm-reminder/pkg-descr
@@ -0,0 +1,7 @@
+[from website]
+A useful plugin for GKrellM that can remind you of important events.
+Events can be scheduled inside GKrellM's configuration and will be
+displayed in gkrellm-reminder's panel.
+
+WWW: http://www.engr.orst.edu/~simonsen/reminder/
+Author: James Simonsen <simonjam@ucs.orst.edu>
diff --git a/misc/gkrellm-reminder/pkg-plist b/misc/gkrellm-reminder/pkg-plist
new file mode 100644
index 00000000000..5b13550b7e5
--- /dev/null
+++ b/misc/gkrellm-reminder/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm/plugins/reminder.so