aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kfile-plugins/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-03-09 21:03:38 +0800
committerlofi <lofi@FreeBSD.org>2004-03-09 21:03:38 +0800
commit8aed08565381603d0f8f319e918b8d99478c2bb8 (patch)
treeb8aa24cd668ee860576e675ee86fb02cd854b005 /misc/kfile-plugins/Makefile
parent5b04f4e2833f4a96f2b95a68fdfc3a0da23248a8 (diff)
downloadfreebsd-ports-graphics-8aed08565381603d0f8f319e918b8d99478c2bb8.tar.gz
freebsd-ports-graphics-8aed08565381603d0f8f319e918b8d99478c2bb8.tar.zst
freebsd-ports-graphics-8aed08565381603d0f8f319e918b8d99478c2bb8.zip
Add kfile-plugins, a collection of plugins for konqueror (part of kdebase) in
filemanager-mode.
Diffstat (limited to 'misc/kfile-plugins/Makefile')
-rw-r--r--misc/kfile-plugins/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/kfile-plugins/Makefile b/misc/kfile-plugins/Makefile
new file mode 100644
index 00000000000..82a08e6e1d6
--- /dev/null
+++ b/misc/kfile-plugins/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kfile-plugins
+# Date created: 11 Febrary 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${KFILEPLUGINS_PORTNAME}
+PORTVERSION= ${KFILEPLUGINS_PORTVERSION}
+PORTREVISION= ${KFILEPLUGINS_PORTREVISION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Plugins for Konqueror (in filemanager mode)
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= ${KFILEPLUGINS_PORTNAME:S/${KDE_SPLIT_DIST}-//}
+KDE_DOC_SPLIT= # none
+USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>