aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pointless
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-07-03 01:37:17 +0800
committererwin <erwin@FreeBSD.org>2003-07-03 01:37:17 +0800
commit4a088613ec96063b7d8bf18721ff198673ebdcf6 (patch)
tree29df5fc86dde1b8b2961da79961a13de4c86e10b /misc/pointless
parent38646d801585b050d5dd4ac3a2987fd579b51651 (diff)
downloadfreebsd-ports-graphics-4a088613ec96063b7d8bf18721ff198673ebdcf6.tar.gz
freebsd-ports-graphics-4a088613ec96063b7d8bf18721ff198673ebdcf6.tar.zst
freebsd-ports-graphics-4a088613ec96063b7d8bf18721ff198673ebdcf6.zip
Pointless is a presentation tool primarily targeted at the un*x
world. Presentations are made using a simple markup-language (best described as a mix between TeX and Pod, and affectionately known as "The Pointless Language"). The resulting slideshow is rendered using FreeType and OpenGL for optimal visual quality. Submitted by: Christian Laursen <xi@borderworlds.dk>
Diffstat (limited to 'misc/pointless')
-rw-r--r--misc/pointless/Makefile33
-rw-r--r--misc/pointless/distinfo1
-rw-r--r--misc/pointless/pkg-descr12
-rw-r--r--misc/pointless/pkg-plist41
4 files changed, 87 insertions, 0 deletions
diff --git a/misc/pointless/Makefile b/misc/pointless/Makefile
new file mode 100644
index 00000000000..c6bbcca2932
--- /dev/null
+++ b/misc/pointless/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pointless
+# Date created: 23 june 2003
+# Whom: Christian Laursen <xi@borderworlds.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pointless
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= xi@borderworlds.dk
+COMMENT= Pointless is a presentation tool primarily targeted at the un*x world
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
+ ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu \
+ ${LOCALBASE}/bin/latex:${PORTSDIR}/print/latex \
+ ${LOCALBASE}/bin/dvips:${PORTSDIR}/print/dvips \
+ ${LOCALBASE}/bin/a2ps:${PORTSDIR}/print/a2ps-letter \
+ ${LOCALBASE}/bin/mpost:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_MESA= yes
+USE_PYTHON= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+
+MAN1= pointless.1
+
+.include <bsd.port.mk>
diff --git a/misc/pointless/distinfo b/misc/pointless/distinfo
new file mode 100644
index 00000000000..8ab871460f1
--- /dev/null
+++ b/misc/pointless/distinfo
@@ -0,0 +1 @@
+MD5 (pointless-0.3.tar.gz) = 5afc024efc7915a160c117f218ddb924
diff --git a/misc/pointless/pkg-descr b/misc/pointless/pkg-descr
new file mode 100644
index 00000000000..7cb55d4fa0b
--- /dev/null
+++ b/misc/pointless/pkg-descr
@@ -0,0 +1,12 @@
+Pointless is a presentation tool primarily targeted at the un*x
+world. Presentations are made using a simple markup-language (best
+described as a mix between TeX and Pod, and affectionately known as
+"The Pointless Language"). The resulting slideshow is rendered using
+FreeType and OpenGL for optimal visual quality. Hardware accelerated
+OpenGL is highly recommended but not required in order to run
+pointless.
+
+WWW: http://www.pointless.dk/
+
+- Christian
+xi@borderworlds.dk
diff --git a/misc/pointless/pkg-plist b/misc/pointless/pkg-plist
new file mode 100644
index 00000000000..225b5d72398
--- /dev/null
+++ b/misc/pointless/pkg-plist
@@ -0,0 +1,41 @@
+share/pointless/samples/bgtiled.pll
+share/pointless/samples/bgstretched.pll
+share/pointless/samples/code.pll
+share/pointless/samples/eps.pll
+share/pointless/samples/gnuplot.pll
+share/pointless/samples/koch5.eps
+share/pointless/samples/latex.pll
+share/pointless/samples/mpost.pll
+share/pointless/samples/pointless.png
+share/pointless/samples/vegetative_fog.png
+share/pointless/samples/viewme.pll
+share/pointless/fonts/FreeSans.ttf
+share/pointless/fonts/FreeSansBold.ttf
+share/pointless/fonts/FreeSansOblique.ttf
+share/pointless/fonts/FreeMonoBold.ttf
+share/pointless/templates/html/index.html
+share/pointless/templates/html/firstsingleshot.html
+share/pointless/templates/html/lastsingleshot.html
+share/pointless/templates/html/singleshot.html
+share/pointless/pointless.xpm
+share/pointless/README
+share/pointless/pointlessrc
+share/pointless/python/modules/pllbasics.py
+share/pointless/python/modules/eps.py
+share/pointless/python/modules/gnuplot.py
+share/pointless/python/merger.py
+share/pointless/python/plfiles.py
+share/pointless/python/pllcontroller.py
+share/pointless/python/pllog.py
+share/pointless/python/pllshared.py
+share/pointless/python/pllmodules.py
+share/pointless/python/ploptions.py
+share/pointless/python/pointless.py
+bin/pointless
+@dirrm share/pointless/samples
+@dirrm share/pointless/fonts
+@dirrm share/pointless/templates/html
+@dirrm share/pointless/templates
+@dirrm share/pointless/python/modules
+@dirrm share/pointless/python
+@dirrm share/pointless