aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-progressbar
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2010-04-07 22:13:06 +0800
committerlioux <lioux@FreeBSD.org>2010-04-07 22:13:06 +0800
commit51c215780ea8e9fe2ae8d4c6bbdbaf5a2977ebd6 (patch)
tree7a1f910c3ca36fe82c1937d82ce2efa71848f39e /misc/py-progressbar
parent5f67967338a7301e2d3e0e27d4f513d7e9487bd7 (diff)
downloadfreebsd-ports-graphics-51c215780ea8e9fe2ae8d4c6bbdbaf5a2977ebd6.tar.gz
freebsd-ports-graphics-51c215780ea8e9fe2ae8d4c6bbdbaf5a2977ebd6.tar.zst
freebsd-ports-graphics-51c215780ea8e9fe2ae8d4c6bbdbaf5a2977ebd6.zip
New port py-progressbar version 2.2: A text progressbar library for python
Diffstat (limited to 'misc/py-progressbar')
-rw-r--r--misc/py-progressbar/Makefile29
-rw-r--r--misc/py-progressbar/distinfo3
-rw-r--r--misc/py-progressbar/pkg-descr19
3 files changed, 51 insertions, 0 deletions
diff --git a/misc/py-progressbar/Makefile b/misc/py-progressbar/Makefile
new file mode 100644
index 00000000000..b393ca66537
--- /dev/null
+++ b/misc/py-progressbar/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: progressbar
+# Date created: Wed Apr 7 13:54:04 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= progressbar
+PORTVERSION= 2.2
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A text progressbar library for python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+INSTALLS_EGGINFO= yes
+
+PLIST_FILES= \
+ %%PYTHON_SITELIBDIR%%/progressbar.py \
+ %%PYTHON_SITELIBDIR%%/progressbar.pyc \
+ %%PYTHON_SITELIBDIR%%/progressbar.pyo
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-progressbar/distinfo b/misc/py-progressbar/distinfo
new file mode 100644
index 00000000000..dfcaf05c7c0
--- /dev/null
+++ b/misc/py-progressbar/distinfo
@@ -0,0 +1,3 @@
+MD5 (progressbar-2.2.tar.gz) = 8ea4e2c17a8ec9e7d153767c5f2a7b28
+SHA256 (progressbar-2.2.tar.gz) = dfee5201237ca0e942baa4d451fee8bf8a54065a337fabe7378b8585aeda56a3
+SIZE (progressbar-2.2.tar.gz) = 5118
diff --git a/misc/py-progressbar/pkg-descr b/misc/py-progressbar/pkg-descr
new file mode 100644
index 00000000000..c9c13f58601
--- /dev/null
+++ b/misc/py-progressbar/pkg-descr
@@ -0,0 +1,19 @@
+This library provides a text mode progressbar. This is tipically
+used to display the progress of a long running operation, providing
+a visual clue that processing is underway.
+
+The ProgressBar class manages the progress, and the format of the
+line is given by a number of widgets. A widget is an object that
+may display diferently depending on the state of the progress.
+
+There are three types of widget:
+
+- a string, which always shows itself;
+
+- a ProgressBarWidget, which may return a diferent value every time
+it's update method is called; and
+
+- a ProgressBarWidgetHFill, which is like ProgressBarWidget, except
+it expands to fill the remaining width of the line.
+
+WWW: http://pypi.python.org/pypi/progressbar/