aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2013-09-25 21:19:44 +0800
committercy <cy@FreeBSD.org>2013-09-25 21:19:44 +0800
commit1cbf8bc45e98c362959c77f901dfc714900b255d (patch)
tree5eb6b3cfddeffaf7a7c493ba569c88b0595c0061 /misc
parent9de3a2f383c8a4e9b127736d6d0578c207c61fdd (diff)
downloadfreebsd-ports-graphics-1cbf8bc45e98c362959c77f901dfc714900b255d.tar.gz
freebsd-ports-graphics-1cbf8bc45e98c362959c77f901dfc714900b255d.tar.zst
freebsd-ports-graphics-1cbf8bc45e98c362959c77f901dfc714900b255d.zip
This port will not work with tclwrapper.
Switch to USE_TK_RUN.
Diffstat (limited to 'misc')
-rw-r--r--misc/tkcron/Makefile5
-rw-r--r--misc/tkcron/files/patch-aa15
2 files changed, 13 insertions, 7 deletions
diff --git a/misc/tkcron/Makefile b/misc/tkcron/Makefile
index ab5d1afca32..4b2cc9d6cbb 100644
--- a/misc/tkcron/Makefile
+++ b/misc/tkcron/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tkcron
PORTVERSION= 2.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.tcl.tk/pub/tcl/mirror/ftp.procplace.com/sorted/packages-7.6/misc/tkcron-2.12/ \
http://ftp.sunet.se/pub/lang/tcl/sorted/packages-7.6/misc/tkcron-2.12/ \
@@ -15,8 +15,7 @@ EXTRACT_SUFX= .tcl.gz
MAINTAINER= cy@FreeBSD.org
COMMENT= A frontend to crontab
-RUN_DEPENDS= wish8.5:${PORTSDIR}/x11-toolkits/tk85 \
- wish:${PORTSDIR}/x11-toolkits/tk-wrapper
+USE_TK_RUN= 85
EXTRACT_CMD= ${GZIP_CMD}
EXTRACT_BEFORE_ARGS= -cd
diff --git a/misc/tkcron/files/patch-aa b/misc/tkcron/files/patch-aa
index b6c4026ef5a..c95b85a1c72 100644
--- a/misc/tkcron/files/patch-aa
+++ b/misc/tkcron/files/patch-aa
@@ -1,6 +1,14 @@
---- tkcron.tcl Sat Aug 3 17:53:42 1996
-+++ tkcron.tcl Sat Aug 3 17:52:03 1996
-@@ -281,6 +281,7 @@
+--- tkcron.tcl.orig 2013-09-25 00:48:19.068508511 -0700
++++ tkcron.tcl 2013-09-25 06:10:06.670101791 -0700
+@@ -1,4 +1,6 @@
+-#!/usr/local/bin/wish
++#! /bin/sh
++# the next line restarts using wish \
++exec /usr/local/bin/wish8.5 $0 ${1+"$@"}
+
+ # A simple interface to ease the creation of crontab jobs
+ # Cedric BEUST (beust@sophia.inria.fr)
+@@ -281,6 +283,7 @@
# Return the crontab string as a list
proc parseCrontabFile {str} {
@@ -8,4 +16,3 @@
set crontablist [split $str \n]
set listlength [llength $crontablist]
for {set i 0} {$i < $listlength} {incr i 1} {
-